Skip to:
Content

Opened 19 months ago

Closed 14 months ago

Last modified 13 months ago

#4566 closed defect (bug) (fixed)

WP 3.5 status comment broken

Reported by: modemlooper Owned by:
Milestone: Priority: normal
Severity: minor Version: 1.6
Component: Activity Keywords: reporter-feedback
Cc:

Description

when you click post on status reply it borks the ajax. If you add a status update and after the ajax immediately try to add a comment its sending you to the url /wp-admin/admin-ajax.php#ac-form-1066 with a white page with a 0 displaying.

If you refresh page or add a comment to another activity item it doesn't use ajax but refreshes the whole page. Post comment with a green notice at top.

Change History (26)

comment:1 DJPaul18 months ago

  • Keywords reporter-feedback added

modemlooper, does this still occur with BP 1.6.1 and the latest WP 3.5 beta?

comment:2 modemlooper18 months ago

Yes, some other borked js with 1.6 and 3.5

comment:3 DJPaul17 months ago

  • Keywords reporter-feedback removed
  • Milestone changed from Awaiting Review to 1.6.2

Moving to 1.6.2 for review (we may have fixed a simliar issue in trunk some time back).

comment:4 DJPaul17 months ago

This is still broken in branch, but seems to work in trunk. Anyone recall fixing this in trunk?

comment:5 johnjamesjacoby17 months ago

  • Resolution set to fixed
  • Status changed from new to closed

I inadvertently fixed this while fixing other activity stream related AJAX issues. Closing as fixed.

comment:6 DJPaul16 months ago

  • Milestone changed from 1.7 to 1.6.3
  • Severity changed from normal to major
  • Version changed from 1.6.1 to 1.6

This is still broken in branch, and has been since 1.6.

comment:7 DJPaul16 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:8 DJPaul16 months ago

The patch attached to #4510 apparently fixes this issue in the 1.6 branch

comment:9 r-a-y16 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

This should be fixed as of r6704.

Closing.

comment:10 jorisvdwijst15 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi DJPaul,

I still see this problem on WPMU 3.5.1 with BP1.6.4.

Regards,
Joris

comment:11 modemlooper15 months ago

Try and delete browser cookies, I had someone yesterday say it was still doing the 0 page error and after clearing browser it reloaded the new javascript.

comment:12 iphonedev4614 months ago

Seems to be working for Activity streams - before you try to load any other option (I.e. mentions, favorites, groups). I'm on Wordpress 3.5.1 and Buddypress 1.6.4. Also, I remember from previous Buddypress versions that comments were posted without refreshing the page. It doesn't do that any more. Tested for theme/plugin conflict, to no avail.

Summary: When I try to comment on the normal "All Members" activity feed, comments are posted, but the page refreshes instead of dynamically sliding up on the page. After you click one of the options for the activity stream, like Friends or Groups or Mentions, the comments refresh, but to http://samplewebsite.com/wp-admin/admin-ajax.php, which returns a white screen with the number 0.

Will this be fixed soon before 1.7?

comment:13 follow-up: modemlooper14 months ago

This is fixed. if you are using a custom theme you will need to copy the ajax.php and global.js from the _inc folder into your custom/child theme's _inc folder

Last edited 14 months ago by modemlooper (previous) (diff)

comment:14 modemlooper14 months ago

  • Keywords close added
  • Resolution set to fixed
  • Status changed from reopened to closed

comment:15 in reply to: ↑ 13 iphonedev4614 months ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to modemlooper:

This is fixed. if you are using a custom theme you will need to copy the ajax.php and global.js from the _inc folder into your custom/child theme's _inc folder

Tried this, cleared browser cache, and this still did not work. Using Frisco for Buddypress, if that's applicable.

comment:16 follow-up: modemlooper14 months ago

It's the Frisco theme not BuddyPress. Contact the theme developer.

comment:17 in reply to: ↑ 16 iphonedev4614 months ago

Replying to modemlooper:

It's the Frisco theme not BuddyPress. Contact the theme developer.

I don't think it matters; I changed to bp-default and it still showed the same issue. No plugin conflicts, either. Many users point out that it happens on multisite (network) WordPress; perhaps that is related to the issue at hand?

comment:18 follow-up: boonebgorges14 months ago

  • Keywords reporter-feedback added
  • Severity changed from major to minor

I can't reproduce this locally.

Please enable a Javascript console (such as the webkit inspector, or Firebug for Firefox). I suggest turning on the "persist" options so that the messages remain after a page refresh. Then attempt to post a comment again, and see if you get any error messages.

No plugin conflicts, either.

How do you know? Are you not running any other plugins?

comment:19 boonebgorges14 months ago

  • Milestone changed from 1.6.3 to Future Release

comment:20 in reply to: ↑ 18 iphonedev4614 months ago

Replying to boonebgorges:

I can't reproduce this locally.

Please enable a Javascript console (such as the webkit inspector, or Firebug for Firefox). I suggest turning on the "persist" options so that the messages remain after a page refresh. Then attempt to post a comment again, and see if you get any error messages.

No plugin conflicts, either.

How do you know? Are you not running any other plugins?

Thank you! I'm getting an

"Uncaught Error: Syntax error, unrecognized expression: form#[object Object] div.error"

that seems to be coming from /wp-includes/js/jquery/jquery.js. I noticed that my version of jQuery != the current version. on wp 3.5.1, was jQuery 1.9.1 included and would this be causing the issue?

I know there are no plugins because I've deactivated all of them before to test, which produced the same result.

comment:21 boonebgorges14 months ago

  • Keywords close removed

iphonedev46 - Do you know how to do js debugging? The fact that you're seeing this error makes me think that the following line in global.js is failing:

var form = button.parent().parent().parent().parent();

What you'd need to do to start debugging is to place the following after that line:

console.log(form);

and then see what shows up in your JS console. It ought to be the <form> element, but my guess is that for some reason it's getting tripped up with all the parent() stuff.

When testing this, please use bp-default, so that we can rule out problems with your specific theme.

comment:22 iphonedev4614 months ago

I tried this, but it didn't return anything except the normal uncaught error. Using bp-default. Commenting out

jq( 'form#' + form + ' div.error').hide();

seemed to bring up ajax-loader.gif again and post comments as normal. But now, the uncaught error finds fault with "form#[object Object] textarea" instead of div.error. A lot of errors are happening because of jquery.js, is this related? I seem to have an older version of jQuery (1.8.3) than the newest available. My latest-updated WordPress install came with this version, however.

Last edited 14 months ago by iphonedev46 (previous) (diff)

comment:23 boonebgorges14 months ago

it didn't return anything except the normal uncaught error.

That suggests that you didn't do it in the right place. It should show *something*, even if it's not an error.

It's unlikely that jQuery 1.8.3 is the issue, but I don't understand why you have an older version of jQuery if you're just running WP, BP and bp-default as you say you are.

Not sure how to move forward. The problem is almost certainly that the selectors in the jQuery are not working. If you have a link to the site and a login that you can share, maybe someone on this site would be able to troubleshoot themselves.

comment:24 modemlooper14 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:25 r-a-y14 months ago

  • Milestone Future Release deleted

comment:26 iphonedev4613 months ago

So for some reason my bp-default was out of date (?!). Thanks for the help, though. Simple fix was to re-upload latest version. Don't know why though, my BuddyPress install is the latest 1.6.5.

Note: See TracTickets for help on using tickets.