Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

#4559 closed defect (bug) (no action required)

Non-english characters break links

Reported by: nyodulf Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6.1
Component: Members Keywords: reporter-feedback
Cc:

Description

Non-english characters in members' names break the links to their profiles. The characters get stripped from the href attribute. Examples include:
Braña
Bönisch
Suárez

The link href is, for example: "domain.com/members/braña/" when viewed in Firebug. Clicking on the link gives a 404 and the url reads "domain.com/members/braa/" . Right-clicking on the link, choosing 'copy link location' and pasting the result into the url bar reads: "domain.com/members/bra%C3%B1a/", but when you try to visit the link it once again gives 404 with the "braa" url.

Change History (5)

#1 follow-up: @r-a-y
8 years ago

  • Keywords reporter-feedback added

How did you create this user?

Currently, BuddyPress only allows you to create usernames with alphanumeric characters.

I also tried to create a user with one of your non-english examples from the WP Admin Users screen into the "Username" field, but could not because WordPress does not allow this.

Did you import these users from some import script?

Last edited 8 years ago by r-a-y (previous) (diff)

#2 in reply to: ↑ 1 @nyodulf
8 years ago

  • Keywords reporter-feedback removed

Replying to r-a-y:

How did you create this user?

Currently, BuddyPress only allows you to create usernames with alphanumeric characters.

I also tried to create a user with one of your non-english examples from the WP Admin Users screen into the "Username" field, but could not because WordPress does not allow this.

Did you import these users from some import script?

I inherited this project and the users were already there. The problem I described was only half present in version 1.5.6 - you could get to a user's page from the list of members, but the admin option link to edit their profile was broken as described above. I upgraded to v1.6.1 in the hope that it would be fixed, but now the problem extends to the normal members list.

Obviously this is not a bug then, but a problem with the site. Sorry for the diversion.

#3 @r-a-y
8 years ago

If you have access, can you check your database under the wp_users table? Look under the user_login column.

If your user_login field does not use non-english characters, you can try and force BuddyPress to use username compatibility mode by adding this snippet:

define( 'BP_ENABLE_USERNAME_COMPATIBILITY_MODE', true );

to wp-config.php or wp-content/plugins/bp-custom.php.

#4 @DJPaul
8 years ago

  • Keywords reporter-feedback added
  • Severity changed from critical to normal

#5 @boonebgorges
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Sounds like this is a config issue, not a bug in BP. If it turns out to be a core bug, please reopen.

Note: See TracTickets for help on using tickets.