Skip to:
Content

Opened 19 months ago

Closed 19 hours ago

#4538 closed enhancement (duplicate)

Using WordPress Menus for BuddyPress Menus

Reported by: modemlooper Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc: modemloper@…

Description

Title says it all. It's been discussed before about using WP menus.

Here's something I came up with to route menu items to bp slugs

https://github.com/modemlooper/BuddyPress-Menus

I think something this could make it into 1.7 for the main nav . The user nav would need to be reworked as plugins would need a way to hook into item creation. Also backpat is an issue.

Change History (9)

comment:1 johnjamesjacoby19 months ago

Neat. Hope to find time to look this week.

comment:2 modemlooper19 months ago

  • Cc modemloper@… added

comment:3 DJPaul18 months ago

  • Keywords reporter-feedback added

Link broken?

comment:4 modemlooper18 months ago

It's bp menus in repo, now. But when I have code that interacts with walker ill put on github

comment:5 modemlooper18 months ago

  • Owner set to modemlooper
  • Status changed from new to assigned

comment:6 DJPaul17 months ago

  • Keywords reporter-feedback removed
  • Milestone changed from Awaiting Review to Future Release
  • Owner modemlooper deleted
  • Version 1.7 deleted

Moving to future-release because I believe this is something we want to do at some point, but we haven't decided upon a technical approach yet.

comment:7 modemlooper17 months ago

sure, after 1.7 and I get all my plugins updated I'm going to test different options with bp-menus plugin.

comment:9 r-a-y19 hours ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from assigned to closed

Duplicate of #5122.

Note: See TracTickets for help on using tickets.