Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 7 years ago

#4534 closed enhancement (fixed)

About default profile fields/tab

Reported by: sgr33n Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Extended Profile Keywords: needs-patch 2nd-opinion
Cc:

Description

As discussed on #4489, I would suggest some enhancement about the way BuddyPress use XProfile.

WordPress profile syncing doesn't seem to work as it should. If you change your BuddyPress "name" field, it will reset both WP nickname and first_name to what you entered.

So I would suggest to leave the base profile on WordPress wp_users and user_meta table, letting BuddyPress change them. They are "first_name", "last_name", "nickname" and "bio".

This could be the profile "info" tab. Then, if the Community Admin want to add more fields, he could populate the XProfile table in the way BuddyPress already do, and choice a name to give the table.

On this scenario BuddyPress could be more integrated into WordPress.

Change History (2)

#1 @johnjamesjacoby
7 years ago

  • Keywords needs-patch 2nd-opinion added
  • Milestone changed from Awaiting Review to Future Release

Ideally we'd have some kind of XProfile field to WordPress usermeta field field map.

I imagine this is a duplicate too; I can remember seeing something similar.

#2 @johnjamesjacoby
7 years ago

  • Milestone Future Release deleted
  • Resolution set to fixed
  • Status changed from new to closed

Duplicate of #4266.

Note: See TracTickets for help on using tickets.