Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 7 years ago

Last modified 7 years ago

#4387 closed defect (bug) (fixed)

Private Groups request membership action is inconsistent for Admins

Reported by: rachelbaker's profile rachelbaker Owned by:
Milestone: Priority: normal
Severity: trivial Version: 1.6
Component: Groups Keywords:
Cc:

Description

When viewing a Group's page of which I am not a member, I can see the "Request Membership" button in the header but I don't have the Request Membership tab.
This is inconsistent with how the page is displayed for other users/roles that are not members of the group.

Attachments (1)

Dummy Private | Home | BuddyPress 1.6 Beta.png (138.6 KB) - added by rachelbaker 12 years ago.
BuddyPress Private Group View for Admin

Download all attachments as: .zip

Change History (7)

@rachelbaker
12 years ago

BuddyPress Private Group View for Admin

#1 follow-up: @boonebgorges
12 years ago

  • Milestone changed from Awaiting Review to Future Release

Yes, this is inconsistent.

The reason is that tabs on private groups are rendered differently for admins than for non-members (admins can see all tabs on all groups, regardless of group status). I don't believe this is a regression - it's been like this for a long time.

rachelbaker, do you have a suggestion for a better UI? Simply adding a Request Membership tab for admins?

#2 in reply to: ↑ 1 @rachelbaker
12 years ago

Replying to boonebgorges:

rachelbaker, do you have a suggestion for a better UI? Simply adding a Request Membership tab for admins?

I have been thinking about this for the past few days, and I can understand why the admin interface is different here. Originally, I was confused why I was missing the "Request Membership" tab while trying to troubleshoot an issue reported by a site's non-admin user (relating to ticket #4382).

I was thinking that the interface for the admins while having the additions, at the same time shouldn't have interface/interaction items removed. I didn't realize that this has been the case over previous releases.

#3 @rachelbaker
12 years ago

  • Keywords 2nd-opinion dev-feedback added

The proposed default theme/theme handling in 1.7 could be a place to fix this if there is anyone else that:
while logged in as admin -> viewing a group of which they are not a member -> didn't realize that they were not a member of the group.

Leaving open for a second opinion/feedback.

#4 @johnjamesjacoby
9 years ago

  • Version changed from 1.6-rc to 1.6

#5 @dcavins
7 years ago

  • Keywords 2nd-opinion dev-feedback removed
  • Resolution set to fixed
  • Status changed from new to closed

This was addressed in r8159, v2.1

#6 @slaFFik
7 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.