Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4377 closed defect (bug) (no action required)

Cannot post activity message

Reported by: sakthi31's profile sakthi31 Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6
Component: Activity Keywords: reporter-feedback
Cc: sakthi31

Description

Installed out of the box Wordpress 3.4.1 and Buddypress RC1; Upon activation using the default theme, tried posting a new activity using whats new, <username> text box and recieved a message "There was a problem posting your update, please try again."

Tried connecting 2 friends, activity shows up and even accepts replies; however strangely still cannot post an update using the whats new box

Change History (10)

#1 @sakthi31
12 years ago

  • Cc sakthi31 added

Even though it presented the message, the update shows up in user profile. However, there is a View link next to the update and it always link to http://localhost/activity/p// (yes 2 forward slashes at the end), which when invoked always throw 404

#2 @DJPaul
12 years ago

  • Keywords reporter-feedback added
  • Severity changed from critical to normal
  • Version changed from 1.6-beta to 1.6-rc

sakthi31, which web browser are you using to recreate this bug?

Moving to 1.6 for review.

#3 @DJPaul
12 years ago

  • Milestone changed from Awaiting Review to 1.6

#4 @sakthi31
12 years ago

Paul,

I could replicate this in IE 8 (both 32 & 64bit), Firefox 12

I first tried this with Bitnami and then with plain WAMP

On a related note, I see a -1 and then the message in IE

Please let me know if you need any other information.

#5 @DJPaul
12 years ago

  • Milestone changed from 1.6 to Awaiting Review

The double slash is appearing because the activity ID is missing (so there's nothing to separate the slashes). I can't recreate.

#6 @boonebgorges
12 years ago

I can't reproduce this either, though it sounds very much like the AJAX request is mostly working, but returning a value that suggests that it's failed.

#7 @r-a-y
12 years ago

@sakthi31 - If you're using Firefox, can you install Firebug?

Once you have it installed, navigate to the "What's new" box. Turn on the Firebug console and now attempt a new activity update.

When you submit the form, an entry should popup in the Firebug console noting the AJAX request.

Expand the entry and if you can take screenshots of each tab, that would be great.

Here's a video tutorial on how to use Firebug:
http://www.dev4press.com/2010/tutorials/wordpress/various/use-firebug-to-track-ajax-requests-and-responses/

#8 @sakthi31
12 years ago

  • Resolution set to invalid
  • Status changed from new to closed

DJPaul,boone,r-a-y,
Apologies for not updating the ticket. I'm still getting this message and found that my web server (IIS) is the issue - I installed everything using WebMatrix2. I even tried using the web.config in the codex, but still I the same message persists.

I changed the web server to Apache and everything works like a charm now!

Thanks for your time

#9 @DJPaul
12 years ago

  • Milestone Awaiting Review deleted

#10 @johnjamesjacoby
9 years ago

  • Version changed from 1.6-rc to 1.6
Note: See TracTickets for help on using tickets.