Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4326 closed defect (bug) (fixed)

BP setup creates dir pages even if I choose to use existing pages

Reported by: luccame's profile luccame Owned by:
Milestone: 1.6 Priority: normal
Severity: major Version: 1.6
Component: New User Experience Keywords:
Cc:

Description

During setup I chose existing pages but BP still created the default ones.

---
Fresh install of WP 3.4.1
Multisite enabled (one site only)
BP trunk @6168

Change History (3)

#1 @boonebgorges
12 years ago

  • Component changed from Core to Update/Install
  • Milestone changed from Awaiting Review to 1.6
  • Severity changed from normal to major

Wow, good catch. The problem is that the field names for the existing page dropdowns are hardcoded with the wrong text.

#2 @boonebgorges
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6169]) Save WP page associations properly during installation

The 'name' attribute of the <select> elements on the Pages tab of the wizard
were previously hardcoded with the incorrect value (they were all called
"...-blogs-..."). As a result, it was impossible to associate components
with existing pages during installation (except for the Blogs component). This
changeset replaces the names with the correct values.

Fixes #4326

#3 @johnjamesjacoby
9 years ago

  • Version changed from 1.6-beta to 1.6
Note: See TracTickets for help on using tickets.