Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 8 years ago

#4324 closed defect (bug)

Private message sent durations are incorrect after first sending.

Reported by: lukejjones's profile LukeJJones Owned by: lukejjones's profile LukeJJones
Milestone: Priority: normal
Severity: normal Version: 1.5.6
Component: Messages Keywords:
Cc:

Description

When I first reply to a private message the time it says "Sent 7 hours ago". When I refresh the correct sent duration is displayed.

Attachments (1)

ReplyTimeBug.PNG (11.9 KB) - added by LukeJJones 12 years ago.
Screenshot of the issue

Download all attachments as: .zip

Change History (7)

@LukeJJones
12 years ago

Screenshot of the issue

#1 @r-a-y
12 years ago

  • Keywords reporter-feedback added

When you reply to a private message with AJAX, BuddyPress uses WordPress' current_time() to grab the GMT time.

Can you test and see if current_time() is working correctly on your install?

eg:

var_dump( current_time( 'gmt', 1 ) );

This should output the GMT time. If this is not accurate, then the time will not be accurate when you first reply the PM.

Let us know.

#2 @johnjamesjacoby
11 years ago

  • Keywords needs-patch dev-feedback added
  • Milestone changed from Awaiting Review to 1.7

There's definitely been something funky with this, since years and years ago.

#3 @johnjamesjacoby
11 years ago

  • Keywords reporter-feedback dev-feedback removed
  • Milestone changed from 1.7 to 1.8

Let's get some eyes on this in 1.8.

#4 @boonebgorges
11 years ago

I haven't been able to reproduce the problem in my tests. Would you mind sharing more details about your server configuration? What timezone are you in? What timezone is your server in? What is your WP timezone setting?

#5 @boonebgorges
11 years ago

  • Milestone changed from 1.8 to Future Release

#6 @r-a-y
8 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Status changed from new to closed

Duplicate of #4310.

Note: See TracTickets for help on using tickets.