Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 11 years ago

Last modified 9 years ago

#4313 closed defect (bug) (no action required)

1.6 beta 1 doesn't show the admin bar for logged out users

Reported by: piano08man's profile piano08man Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6
Component: Core Keywords:
Cc:

Description

Just upgraded a development site from 1.5.6 to 1.6 beta 1 and can’t figure out why the admin bar won’t show up for logged out users. I like how it works on here, where the user can login directly from the admin bar. I’d also like to see a register link up there, but as it stands, I don’t see the bar at all when I’m logged out.

creatorsboard.com

Change History (6)

#1 @boonebgorges
12 years ago

  • Keywords reporter-feedback added

Could you check Dashboard > Settings > BuddyPress > Settings to see whether you've enabled the admin bar for logged-out users?

#2 follow-up: @DJPaul
12 years ago

We fixed some issues regarding the toolbar settings in ticket #3661. Need further details from reporter to be confident we've already addressed this issue.

#3 in reply to: ↑ 2 @piano08man
12 years ago

  • Keywords reporter-feedback removed

Replying to DJPaul:

We fixed some issues regarding the toolbar settings in ticket #3661. Need further details from reporter to be confident we've already addressed this issue.

I looked at 3661, some of the changes were in beta two. My 'true' was originally set to 'false'.

if ( (bool) bp_get_option( '_bp_force_buddybar', false ) ) {


I still can't get the buddy bar to show up properly after that initial upgrade. I'm guessing that the upgrade problem wouldn't be an issue with the new code, but this upgrade is probably fubar'd. A normal person would start over...

#4 @DJPaul
12 years ago

  • Keywords reporter-feedback added

Right, you might need to dive into the wp_options table and delete the _bp_force_buddybar option. Can you try this please, and let us know if you still have a problem with BP 1.6.1?

#5 @DJPaul
11 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Closing ticket as no follow-up from original reporter in 4 months. I believe this issue was caused by us flipping the behaviour of the "force buddy/admin bar" options during 1.6 development; I've not seen any other reports of this, which I would have expected to, had it been widespread.

#6 @johnjamesjacoby
9 years ago

  • Version changed from 1.6-beta to 1.6
Note: See TracTickets for help on using tickets.