Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4311 closed defect (bug) (fixed)

Fatal error: Call to undefined function bp_get_settings_slug()

Reported by: Spitzohr Owned by:
Milestone: 1.5.7 Priority: normal
Severity: normal Version: 1.5.5
Component: Groups Keywords:
Cc:

Description

We're using BuddyPress (1.5.5) together with the Invite Anyone Plugin (Version 1.0.8). If a user try to invite an user to a group, the following message appears:

Fatal error: Call to undefined function bp_get_settings_slug() in /srv/www/blogs/rsconnect/wp-content/plugins/buddypress/bp-groups/bp-groups-notifications.php on line 223

Here is the line 223:
$settings_link = bp_core_get_user_domain( $invited_user_id ) . bp_get_settings_slug() . '/notifications/';

Several functions in this file uses bg_get_settings_slug(), but they check if the function exists:

$settings_slug = function_exists( 'bp_get_settings_slug' ) ? bp_get_settings_slug() : 'settings';

Change History (4)

#1 @Spitzohr
9 years ago

  • Component changed from Core to Groups

#2 @boonebgorges
9 years ago

  • Milestone changed from Awaiting Review to 1.5.7

Confirmed.

#3 @boonebgorges
9 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6147]) Fixes fatal error in group invite notification when Settings is disabled

groups_notification_group_invites() assembles an email notification that
includes a link to the user settings page. This link cannot be directly
concatenated using bp_get_settings_slug(), since the latter function is not
defined when Settings is disabled.

Fixes #4311

Props Spitzohr

#4 @boonebgorges
9 years ago

(In [6148]) Fixes fatal error in group invite notification when Settings is disabled

groups_notification_group_invites() assembles an email notification that
includes a link to the user settings page. This link cannot be directly
concatenated using bp_get_settings_slug(), since the latter function is not
defined when Settings is disabled.

Fixes #4311

Props Spitzohr

Note: See TracTickets for help on using tickets.