Skip to:
Content

BuddyPress.org

Opened 7 years ago

Closed 3 years ago

Last modified 3 years ago

#4308 closed defect (bug) (fixed)

User profiles can not be opened when Members Directory is set as sub page.

Reported by: sofianjanom Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.6
Component: Members Keywords:
Cc:

Description

Using the "define ('BP_ENABLE_ROOT_PROFILES', true);" configuration, user profile page can not be opened when Members Directory is set as sub page.

I'm using BP 1.5.6 and WP 3.4.

Attachments (1)

user-profile-page-can-not-opened.jpg (55.7 KB) - added by sofianjanom 7 years ago.

Download all attachments as: .zip

Change History (4)

#1 @boonebgorges
7 years ago

  • Milestone changed from Awaiting Review to Future Release

Confirmed. This is an issue with bp_core_load_template(), and in particular, the way we check for the existence of a root page. I suppose we have to add a special case for bp_core_enable_root_profiles(), which will manually set the $object_id. I just tried this in my sandbox, and it worked, but it uncovered a bunch of other issues that must arise in the catchuri method.

Since this is not a regression, it's not urgent to fix at the moment. Let's look at it for the next cycle.

#2 @lakrisgubben
3 years ago

  • Resolution set to fixed
  • Status changed from new to closed

This was fixed in r10212 see ticket #6477

#3 @slaFFik
3 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.