Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 6 years ago

#4303 closed enhancement (maybelater)

Updates to Blog posts are not reflected in the Activity Feed

Reported by: jchew's profile jchew Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.6
Component: Activity Keywords: trac-tidy-2018
Cc:

Description

It appears that updates (edits) made to blog posts are not reflected in the wp_bp_activity table in the 1.6 beta 1 whereas they are in version 1.5.6. Thanks.

Change History (8)

#1 @jchew
12 years ago

  • Component changed from Core to Activity

#2 @boonebgorges
12 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Correct. This is to prevent people from bumping their blog posts. See #3746 and r5562.

If you want to continue the bumping behavior, you might consider building your own activity function for blog post edits.

#3 @jchew
12 years ago

Not to press the issue, especially seeing as I'm a new-comer to the trac here, but that doesn't seem to be the best solution to the problem.

Could you possibly use the post_date timestamp for the rather than post_modified one, or have it so the update does not push the updated timestamp to the wp_bp_activity table at all? It seems to me that simply not updating the Activity Feed when a post is edited creates a disconnect between the blog section and the activity feed section and creates the feeling of degradation rather than enhancement.

#4 @boonebgorges
12 years ago

  • Milestone set to Future Release
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Type changed from defect (bug) to enhancement

Not to press the issue

Pressing the issue is more than welcome, as long as it's civil :)

The behavior in BP 1.5.x is pretty clearly a bug. Post edits should *not* be saved as new_blog_post, and they should not display the text "Boone wrote a new blog post...". That's simply incorrect.

However, I do think it's a reasonable suggestion that edits/updates *should* be recorded. I can imagine lots of cases where this would be useful. I'm going to reopen this and change it to an enhancement ticket so that the dev team can discuss it, or someone can write a patch.

In the meantime, if you would like to implement the behavior in a plugin, here's the strategy. Copy the function bp_blogs_record_post(), along with the associated add_action() line, into your own plugin file (or functions.php, or bp-custom.php). Change the name of the function (don't forget the add_action() call). Then change the $existing logic so that instead of checking whether it's *not* empty, you check whether it *is*:

if ( empty( $existing['activities'] ) ) {
    return;
} 

Then, I'd suggest changing the activity type from new_blog_post to edited_blog_post, and change the language to something like "Boone edited the blog post...".

In the future, we'll investigate whether it makes sense to do something like this in BP itself. My gut feeling is that we may want to wait until it's a bit easier to fine-tune the display of the activity stream, because I have a feeling that showing blog post edits will *not* make sense for the majority of BP sites.

Thanks for the push ;)

#5 @johnjamesjacoby
9 years ago

  • Version changed from 1.6-beta to 1.6

#6 @DJPaul
8 years ago

@imath did this behaviour change recently?

#7 @DJPaul
6 years ago

  • Keywords trac-tidy-2018 added

We're closing this ticket because it has not received any contribution or comments for at least two years. We have decided that it is better to close tickets that are good ideas, which have not gotten (or are unlikely to get) contributions, rather than keep things open indefinitely. This will help us share a more realistic roadmap for BuddyPress with you.

Everyone very much appreciates the time and effort that you spent sharing your idea with us. On behalf of the entire BuddyPress team, thank you.

If you feel strongly that this enhancement should still be added to BuddyPress, and you are able to contribute effort towards it, we encourage you to re-open the ticket, or start a discussion about it in our Slack channel. Please consider that time has proven that good ideas without contributions do not get built.

For more information, see https://bpdevel.wordpress.com/2018/01/21/our-awaiting-contributions-milestone-contains/
or find us on Slack, in the #buddypress channel: https://make.wordpress.org/chat/

#8 @DJPaul
6 years ago

  • Milestone Awaiting Contributions deleted
  • Resolution set to maybelater
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.