Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 9 years ago

#4279 closed defect (bug) (fixed)

BP 1.6beta1 : activity_type in WordPress Backend (unset updated_profile)

Reported by: imath's profile imath Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version: 1.6
Component: Administration Keywords: has-patch commit
Cc:

Description

In the new (and great) WordPress Administration activity menu, i've noticed that there was in the activity_type filter (selectbox) the item 'updated_profile'. But after some tests and reading the code,it seems the profile change are not tracked in activity recordings.

So i think, this type of activities should be unset. I tried to build some functions as a plugin to creates the activity recordings depending on the visibility of the profile field (if public, then it records an activity). So just in case, you can download the code from my dropbox https://dl.dropbox.com/u/2322874/bp-record-profile-activity.zip.

Attachments (1)

bp-activity-admin.diff (591 bytes) - added by imath 12 years ago.
bp-activity-admin.diff

Download all attachments as: .zip

Change History (6)

@imath
12 years ago

bp-activity-admin.diff

#1 follow-up: @DJPaul
12 years ago

  • Milestone changed from Awaiting Review to 1.6

Good spot. After some searching, it turns out that the 'updated_profile' activity type was last used in BP 1.0.3 about three years ago (probably making it our longest regression that no-one noticed): http://buddypress.trac.wordpress.org/browser/tags/1.0.3/bp-xprofile.php#L540

In a future version, we should reinstate the updated_profile activity type. I think imath's patch is the best approach for now. Another would be to remove the bp_activity_set_action() call, but that might break things for anyone who is using that activity type somehow.

#2 in reply to: ↑ 1 @boonebgorges
12 years ago

Replying to DJPaul:

I think imath's patch is the best approach for now.

+1

#3 @boonebgorges
12 years ago

  • Keywords commit added

#4 @djpaul
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6123]) Remove the 'updated_profile' activity type from the filter in the Activity admin screen to de-clutter.
Fixes #4279, props imath.

  • updated_profile was last used in BP 1.0.3.
  • It will be re-instated in a future release.

#5 @johnjamesjacoby
9 years ago

  • Version changed from 1.6-beta to 1.6
Note: See TracTickets for help on using tickets.