Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 8 years ago

#4264 closed defect (bug) (fixed)

Activity Item duplicated when posting new update and clicking ’Load More’

Reported by: pixelflat's profile pixelflat Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Activity Keywords:
Cc:

Description

When posting a new update to the activity stream and clicking the ‘Load More’ Button, the last item in the stream will appear a second time.
This happens in all activity streams…

Change History (12)

#1 @boonebgorges
12 years ago

  • Cc djpaul johnjamesjacoby removed

No need to add devs to the CC list. We all follow incoming tickets.

I'm not able to reproduce your issue on my clean installs. Can you give more information about your setup? WP/BP versions, active theme and plugins. If you're running a custom theme and a lot of plugins, try switching to BuddyPress Default and switching off plugins to see if the problem is related to one of these add-ons.

#2 @DJPaul
12 years ago

I can recreate on http://testbp.org/activity/. Post an update in the What's New box (via javascript), then without reloading the page, scroll down to the bottom of the activity list. Note what the last activity in the list is, then click the 'Load More' button.

#3 @DJPaul
12 years ago

  • Severity changed from major to normal

#4 @pixelflat
12 years ago

OK thanks for the tip...
Well, you can reproduce it also on testbp.org
Post something into the (for example) global activity stream hit post update and click the 'Load More' button. The last activity item in the stream will appear a second time after loading more.

I'm running a online version with 1.6 and two clean local versions (1.5.5 and 1.6) and two online clean versions. All with WordPress 3.3.2. The Bug is on all sites...

#5 @boonebgorges
12 years ago

  • Milestone changed from Awaiting Review to Future Release

My bad, I missed the part where you have to post a new update first.

This is going to be very tricky to fix, because bp_has_activities() does not take an 'offset' parameter, which we'd need to get, eg, items 4-23. We have to query in a paginated way (page 2, ie 20-39). It's an annoying issue, but not serious, as it doesn't actually hide any data. Let's have a look during the next dev cycle.

#6 @pixelflat
12 years ago

@boonebgorges But what about a little workaround? Maybe something like that:

If there is a new update then hide the last update (fade out or so)

Is this possible?

#7 @boonebgorges
12 years ago

Is this possible?

Anything is possible, but solving this in Javascript seems unwise to me. If you've got a patch to suggest, I'd be more than willing to consider including it.

#8 @pixelflat
12 years ago

Looks really hard to do.. I've got a last idea for a workaround ;) :

When posting a new item refresh just the activity stream with ajax this would reorder the items (maybe)

Any other ideas were to start?

#9 @boonebgorges
12 years ago

That's not a terrible idea, but it's a pretty big change in the way the JS currently works - so, again, it will take a lot of work to implement.

#10 @pixelflat
12 years ago

'Load More' makes a lot of problems... When using search_terms= with the activity loop and clicking the 'Load More' Button it will load also activity items without the search_term inside the content - It displays all items
Any idea?

#11 @modemlooper
11 years ago

still broken on 1.7

#12 @slaFFik
8 years ago

  • Keywords needs-patch removed
  • Milestone Future Release deleted
  • Resolution set to fixed
  • Status changed from new to closed

Already fixed in #4897.

Note: See TracTickets for help on using tickets.