Skip to:
Content

Opened 6 years ago

Closed 4 years ago

Last modified 18 months ago

#4247 closed enhancement (duplicate)

Synchronize blog comments and activity stream comments

Reported by: ZehrGut Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.5
Component: Activity Keywords:
Cc: leho@…

Description

Hello!

First of all thanks a lot for your hard work!

It seems quite strange to me that blog comments are not comments in activity stream. They are updates in activity stream. Let me explain my thoughts.

All test are done on testbp.org

For example, I make a comment on a blog post (please look at attached img1.png).
Then I see my comment as an update in activity stream (attached img2.png)
But I can't see my comment as a reply on the post in activity stream (please look at img3.png).

So we have 2 different streams of comments on the same blog post.

Currently I'm choosing a social network script for a project and such behavior completely confused me.

BTW other SN scripts don't use such logic but I love WP platform that is why I decided to ask about it here.

Thanks in advance!

Attachments (3)

img1.png (16.4 KB) - added by ZehrGut 6 years ago.
Comment on the blog post
img2.png (15.9 KB) - added by ZehrGut 6 years ago.
Comment like update on the activity stream
img3.png (61.6 KB) - added by ZehrGut 6 years ago.
a new post on activity stream without my comment

Download all attachments as: .zip

Change History (10)

@ZehrGut
6 years ago

Comment on the blog post

@ZehrGut
6 years ago

Comment like update on the activity stream

@ZehrGut
6 years ago

a new post on activity stream without my comment

#1 @boonebgorges
6 years ago

  • Milestone changed from Awaiting Review to Future Release

BP has a setting "Disable activity stream commenting on blog and forum posts?" which is meant to address this issue. We don't have it enabled on testbp.org, but you will probably want to enable it on your site. See also #3909.

It's worth exploring the repercussions if we were to enable syncing.

#2 @ZehrGut
6 years ago

Thanks a lot for such soon reply!

I've seen https://buddypress.trac.wordpress.org/ticket/3909 before posting my ticket. But there is not any conclusion over there. That is why I've posted my ticket.

Then I will try to play on localhost first.

Also could you please clarify your reply a little bit? Should we hope to have it working the way I was talking in any future release? I mean to see my blog comment as a reply on the post in activity stream.

Thanks in advance!

#3 @boonebgorges
6 years ago

Should we hope to have it working the way I was talking in any future release? I mean to see my blog comment as a reply on the post in activity stream.

I mean that we will have to explore this. It's not very difficult technically, but there are a lot of side issue that arise with this kind of synchronization, which we will have to discuss.

This ticket was mentioned in IRC in #buddypress-dev by r-a-y. View the logs.


4 years ago

#5 @rogercoathup
4 years ago

This was mentioned in the IRC log as a 2.0 item, but still showing as "future release" in the trac.

Is it likely to make it into 2.0?

Thanks, Roger

#6 @boonebgorges
4 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Marking this as a duplicate of #5130, which has patches.

#7 @lkraav
18 months ago

  • Cc leho@… added
Note: See TracTickets for help on using tickets.