Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#4244 closed defect (bug) (no action required)

Strange Issues with BuddyPress Template Pack

Reported by: studio-vanguard's profile Studio Vanguard Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.5
Component: Appearance - Template Pack Keywords: reporter-feedback
Cc:

Description

Hi there,

I've just successfully installed BuddyPress into my own responsive WordPress theme. The process went without a hitch up until step three of the BuddyPress Template Pack plugin. I overwrote all of the 16 file's containing divs with my responsive div classes, however after uploading, the files would not update in the browser. I tried across different browsers, cache flushes etc but nothing was working. After much head scratching, I went through and made the changes to all 16 files, uploaded them all and then clicked to the next step. Much to my relief, clicking the default BuddyPress links brought up pages that had my div containers applied to them. After I did this, suddenly all of the pages started displaying correctly with the updated div containers.

I'm not sure if this was a server issue on my end or a caching issue with the plugin, but it was quite a fluke that I got it work without too much stress. I could imaging a lot of developers wanting to jump off a bridge at this point without any tips or guidance on the issue. Also, I would suggest rewriting the steps for step three of the plugin as I took me a lot of head scratching to figure out what was trying to be said. There has been a lot of other people complaining about this step on the WP forums as well. Aside from that, I was very impressed with my first experience developing for BuddyPress! Looking forward to developing this platform further!

Regards,

James Banks
Founder/President
Studio Vanguard

Change History (2)

#1 @boonebgorges
12 years ago

  • Keywords reporter-feedback added

Thanks for the feedback and the report, James.

When you said

I overwrote all of the 16 file's containing divs with my responsive div classes

which files were you talking about? Were you modifying the files as they existed *in your theme directory* or *in the BP Template Pack plugin*?

The plugin itself doesn't do any caching that would result in what you've suggested here. If you're running an HTML page caching plugin (like Super Cache), it might be at the root of your problem, though even then it would be a pretty big coincidence that it would suddenly clear itself up.

#2 @DJPaul
12 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Going to close this ticket as we've not had a response from the reporter in the 6 months since the ticket was created, and it looks like it may have been an issue with, or confusion caused by, the template pack plugin; the theme compatibility stuff in BP 1.7 should negate this.

Note: See TracTickets for help on using tickets.