Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 11 years ago

Last modified 8 years ago

#4241 closed defect (bug) (fixed)

bp_core_is_root_component() missing in BP 1.5+

Reported by: djpaul's profile DJPaul Owned by:
Milestone: 1.6.2 Priority: normal
Severity: normal Version: 1.5
Component: Core Keywords:
Cc:

Description

The bp_core_is_root_component function did not make it into the 1.5 branch or trunk. It was removed in r3728/#2600.

I found this when updating a site from 1.2.x to 1.5.x which was using this in a custom plugin.

Change History (5)

#1 @DJPaul
12 years ago

  • Milestone changed from Future Release to 1.6.2

#2 @djpaul
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6474]) Bring back bp_core_is_root_component(), and deprecate it in favour of bp_is_root_component().

  • This function was renamed in r3728/#2600 for 1.5, but we broke backpat as we missed adding the deprecated version.

Fixes #4241

#3 @djpaul
11 years ago

(In [6475]) Bring back bp_core_is_root_component(), and deprecate it in favour of bp_is_root_component() (1.6 branch version).

  • This function was renamed in r3728/#2600 for 1.5, but we broke backpat as we missed adding the deprecated version.

Fixes #4241

#4 @johnjamesjacoby
9 years ago

  • Component changed from Backwards Compatability to Warnings/Notices

#5 @DJPaul
8 years ago

  • Component changed from Tools - Warnings/Notices to Core
Note: See TracTickets for help on using tickets.