Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4198 closed defect (bug) (fixed)

"Send to" Auto-Complete Broken When There is Greater Than One Result

Reported by: SlothLoveChunk Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version:
Component: Messages Keywords:
Cc:

Description

Was doing a little more testing with the private message auto-complete functionality and I stumbled across another bug. In a nutshell, if there is more than one result in the auto-complete list, upon clicking a user name it will return the inner contents of the "ac_over" <li>, not an individual user. If there is only one user name in the list all works as it should.

To replicate it's best if you have a decent amount of friends. Now:

  1. Head to /members/<your user name>/messages/compose/
  1. In the "Send to" input enter a generic string that matches at least two of your friends.
  1. If there is more than one result in the auto-complete dropdown click any user name and it should populate the, "send-to-input" with the inner contents of the "ac_over" <li>.

Thanks for taking a look.

P.S. I was curious if anyone has had a chance to look at the pagination bug I submitted a couple weeks ago (#4165 )? No big deal if not, just curious.

Change History (3)

#1 @boonebgorges
10 years ago

  • Milestone changed from Awaiting Review to 1.6

Confirmed. Looking into it.

#2 @boonebgorges
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6021]) Restore the line break between messages autocomplete results that serves as a delimiter for the autocomplete script. Fixes #4198

#3 @boonebgorges
10 years ago

Good find. It was being caused by a minor refactor that had removed the trailing line break between results when compiled by the AJAX handler, which meant that the autocomplete script couldn't tell the results apart.

Thanks for testing trunk!

Note: See TracTickets for help on using tickets.