Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 4 years ago

#4188 closed defect (bug)

Activity pages incorrectly return no results when the previously selected activity filter doesn't exist for the current activity context

Reported by: chriskeeble Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.2
Component: Activity Keywords:
Cc:

Description

WP version 3.3.2
BP 1.5.5

The message: 'Sorry, there was no activity found. Please try a different filter.' is displayed if these steps are followed:

  1. View the main Activity page
  2. Change the filter to one which doesn't exist on the single Group activities page, i.e. one of: Posts, Comments, New Groups, Friendships, New Members
  3. Navigate to a single Group and view activities.

Expected behaviour:

  • Last used activity filter doesn't exist, so use default filter ('Everything')

Actual behaviour:

  • Everything filter is selected (by default) in the dropdown, but
  • The previously selected filter is still being applied, resulting in incorrect results and (in most cases) the message being displayed:

'Sorry, there was no activity found. Please try a different filter.'

The root of the problem is that a single cookie is being stored for activity filtering ('bp-activity-filter') regardless of which page or context we are in.

Ideally, a separate filter value (and cookie) should be used for each context:

  • Activity Page
  • Group Activity
  • Member Activity
  • (others?)

bp-activity-filter

Change History (5)

#1 @chriskeeble
8 years ago

  • Component changed from Core to Activity

#2 @DJPaul
8 years ago

  • Milestone changed from Awaiting Review to Future Release
  • Severity changed from major to normal
  • Version changed from 1.5.5 to 1.2

Yes, it's been like this since 1.2.

#3 @boonebgorges
8 years ago

I think the *real* ideal would be either:
(a) Store a separate cookie for *every* activity page (each separate member, each separate group, etc) - after all, the same logic you've laid out above could apply equally between members or groups; or
(b) Stop storing these cookies at all. I don't think that the user gets very much benefit out of it, and frankly, the entire bp_ajax_querystring() beast is one of the hardest parts of BP to extend/modify, and it's largely due to the cookie logic.

When it comes time to redo the theme, I'm in favor of (b), dropping it altogether.

#4 @chriskeeble
8 years ago

@boonebgorges - yes, I would also be in favour of (b), dropping it altogether for the reasons you state.

#5 @lakrisgubben
4 years ago

  • Milestone Future Release deleted
  • Status changed from new to closed

closing this as a duplicate of #4062 on which I've also added a patch that fixes the problem.

Note: See TracTickets for help on using tickets.