Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

#4180 closed defect (bug) (fixed)

Autocomplete bug, 'bp_dtheme_ajax_messages_autocomplete_results' not firing

Reported by: SlothLoveChunk Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version:
Component: Messages Keywords:
Cc:

Description

I noticed that the private message auto-complete functionality no longer seems to works under 1.6 (latest rev). I've tested using the default BP theme with all plug-ins disabled (except BP of course). Enabling username compatibility mode and/or 'BP_MESSAGES_AUTOCOMPLETE_ALL' doesn't seem to help either.

A few notes based on my tests:

  • The activity indicator DOES appear in the input field, but no results are returned below said input. The indicator just disappears after a few seconds.
  • All JS auto-complete libs are properly being included.
  • The 'jquery.autocomplete.js' ajax request function is returning the parsed search string.
  • I've tried writing to the error log from the 'bp_dtheme_ajax_messages_autocomplete_results' function, but nothing ever appears in the logs.

Based on these tests my hunch is 'bp_dtheme_ajax_messages_autocomplete_results' is not getting executed, which is preventing the auto-complete list from populating.

Can anyone reproduce this? I really hope it's not just me.

Note, sending PMs still works.

Change History (9)

#1 @SlothLoveChunk
8 years ago

Well, I should have known.

After posting this I read that as of 1.6 all calls to 'wp-load.php' are being replaced with 'admin-ajax.php'. After a quick search I found that in, 'bp-messages.cssjs.php' on line 57 'jQuery("ul.first").autoCompletefb' still calls wp-load. After updating it to 'admin-ajax.php' auto-complete works again!

I would create a diff for this, but I honestly have no idea how. Would love to learn though!

#2 @DJPaul
8 years ago

  • Milestone changed from Awaiting Review to 1.6

Great catch. Thanks again for testing trunk!

#3 @djpaul
8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6011]) Update ajax URL for messaging autocomplete. Fixes #4180, props SlothLoveChunk

#4 @SlothLoveChunk
8 years ago

Woot! Thanks.

#5 @DJPaul
8 years ago

About how to make a patch: catch about halfway through this presentation http://www.slideshare.net/kimparsell/becoming-a-wordpress-beta-tester I hope it helps. Beyond that, you're welcome to get in contact and I'll give you a hand.

#6 @Mqlte
8 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hi,

I've got the same problem. I also updated the line to "admin-ajax.php" but still doesn't work for me. I just can see now a loading circle, a list appears but it contains no users, only a "0".

Screenshot: http://i47.tinypic.com/f1y14k.jpg

Sorry for re-opening the ticket.

Regards

Last edited 8 years ago by Mqlte (previous) (diff)

#7 @DJPaul
8 years ago

Mqlte, are you using trunk (1.6)? If so, what revision?

#8 @Mqlte
8 years ago

Thanks for your answer. I'm not using 1.6. Honestly, I don't know how to download the whole trunk-folder. ;)

#9 @DJPaul
8 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In that case, please would you post on our support forums, http://buddypress.org/? This ticket was specific to a change we've made in the upcoming 1.6 version, and you've probably got a conflict with something running on your site, causing a similar error. The admin-ajax.php change definitely will produce 0s for you on BP 1.5.x, as you've discovered.

If it turns out you've got another bug in BP 1.5.x, we can create a new ticket for it. Thanks.

Note: See TracTickets for help on using tickets.