Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4164 closed enhancement (fixed)

Deleting a Comment by Registered User Doesn't Remove it from the Activity Stream

Reported by: SlothLoveChunk Owned by: DJPaul
Milestone: 1.6 Priority: normal
Severity: normal Version: 1.5.5
Component: Activity Keywords:
Cc:

Description

Hi, first time reporting a bug, so let me know if there is more info you need.

BP: 1.6
WP: 3.3.2

Comments posted by SPAM/BOT users are almost always caught and flagged as by Askimet; however, these comments still appear in the Buddypress Activity stream. Ideally, these comments would be excluded from Activity unless they happened to be manually marked as, "Not SPAM" by an admin.

Change History (7)

#1 @SlothLoveChunk
10 years ago

Sorry, I should clarify: "SPAM/BOT 'registered' users".

#2 @DJPaul
10 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Type changed from defect (bug) to enhancement

Not a bug, as this would be a new feature… but, good news! This has been built into BuddyPress 1.6. For further info, see commits r5328 & #3660

#3 @SlothLoveChunk
10 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Thanks for the clarification @DJPaul; however, I think there is a loophole that should be looked at for 1.6. Let me explain.

Indeed, if a comment transition is made (i.e. you trash or flag a comment as SPAM) the corresponding entry in the activity stream is removed. However, if a comment by a spambot registered user is automatically marked as SPAM by Askimet then a transition never occurs, and therefore the 'transition_comment_status' action never fires (at least that is what I've observed). This loophole allows obvious SPAM to penetrate the Activity stream.

Also, because SPAM comments are put under their own section in WP comment admin, it's difficult to spot these entries in the Activity feed (this is especially true if you have a highly active community).

Obviously, taking steps to curtail spambot users is extremely important, but despite even the best efforts some will get through. IMO, before the Activity stream is updated with a comment it should check to see if it has already been marked as SPAM.

I hope this makes sense and warrants the reopened status. If not, I apologize in advance.

#4 @DJPaul
10 years ago

  • Milestone set to 1.6
  • Owner set to DJPaul
  • Status changed from reopened to assigned

Ah, good catch. We'll check it out.

#5 @DJPaul
10 years ago

Got it. Thanks very much for testing and finding this, SlothLoveChunk.

#6 @djpaul
10 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6008]) Fix new comment activity item not being marked as spam if comment was (i.e. by Akismet). Fixes #4164

#7 @SlothLoveChunk
10 years ago

Awesome! Glad I could help.

BTW, SlothLoveChunk is a Goonies reference. I've updated my avatar accordingly. :)

Note: See TracTickets for help on using tickets.