Skip to:
Content

Opened 2 years ago

Closed 6 weeks ago

#4155 closed defect (bug) (invalid)

bp_has_members filter type=online is not working

Reported by: hridaya Owned by: HRidaya
Milestone: Priority: normal
Severity: normal Version: 1.7
Component: Members Keywords:
Cc: solhuebner

Description

i am going to show the online members list by filtering
if ( bp_has_members( ‘type=online&per_page=30′) ){

}

its all working on my dev server and localhost type=online but when i moved to live the type=online is not working any more whether all other options :: active, newest, popular, alphabetical, random works only ‘online’ options is not working .
What may be the cause can you please share idea if you have any.

Change History (5)

comment:1 DJPaul2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

I've just tested, and this works. There is a forum post from the reporter at http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/bp_has_members-filter-typeonline-is-not-working/.

If you can share some more of your template on your forum topics, we'll work with you to figure it out. It doesn't appear to be a bug in BuddyPress.

comment:2 hridaya2 years ago

please look on the forum post i have added my templates codes over there. Yes i know its but the buddypress bug as its working on the dev server and my localhost.

Last edited 2 years ago by hridaya (previous) (diff)

comment:3 GencHaritaci12 months ago

  • Component changed from Core to Members
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Version changed from 1.5.1 to 1.7

I have smilar problem,

I use code below to show popular members but its working at localhost and not working on server. All other filters (ramdom, active, newest, online, etc..) working but "popular" filter not working except for localhost.

<?php if (bp_has_members('type=popular&max=8')) : ?>			
			<?php while (bp_members()) : bp_the_member(); ?>						
				<a href="<?php bp_member_permalink() ?>" class="front-member-item"><?php bp_member_avatar('type=full&width=60&height=60') ?></a>
			<?php endwhile; ?>
<?php endif; ?>

comment:4 solhuebner8 months ago

  • Cc solhuebner added

comment:5 boonebgorges6 weeks ago

  • Resolution set to invalid
  • Status changed from reopened to closed

Closing due to lack of activity. GencHaritaci, if you are still having problems with the 'popular' filter, consider opening a new ticket with details. Thanks.

Note: See TracTickets for help on using tickets.