Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 8 years ago

Last modified 6 years ago

#4130 closed enhancement (no action required)

Grab component page title from the WordPress page title.

Reported by: sooskriszta's profile sooskriszta Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.4
Component: Core Keywords: needs-patch
Cc: karmatosed@…, vivek@…, mercijavier@…

Description

BP provides the functionality to change names and slugs of components via the config file.

It would be nice if like bbPress, these options are provided in the WP admin panel.

e.g.

define ( 'BP_ACTIVITY_SLUG', 'streams' );
define ( 'BP_BLOGS_SLUG', 'journals' );
define ( 'BP_MEMBERS_SLUG', 'users' );
define ( 'BP_FRIENDS_SLUG', 'peeps' );
define ( 'BP_GROUPS_SLUG', 'gatherings' );
define ( 'BP_FORUMS_SLUG', 'discussions' );
define ( 'BP_MESSAGES_SLUG', 'notes' );
define ( 'BP_WIRE_SLUG', 'pinboard' );
define ( 'BP_XPROFILE_SLUG', 'info' );
define ( 'BP_REGISTER_SLUG', 'signup' );
define ( 'BP_ACTIVATION_SLUG', 'enable' );
define ( 'BP_SEARCH_SLUG', 'find' );
define ( 'BP_HOME_BLOG_SLUG', 'news' );

Change History (18)

#1 @sooskriszta
12 years ago

  • Component changed from Core to Administration

#2 @sooskriszta
12 years ago

  • Component changed from Administration to UX/UI

#3 @DJPaul
12 years ago

  • Milestone changed from Awaiting Review to Future Release

#4 @sooskriszta
12 years ago

  • Summary changed from Change component names and slugs to Add admin panel options to change component names and slugs

#5 @sooskriszta
12 years ago

  • Version changed from 1.5.4 to 1.5.5

#6 @sooskriszta
11 years ago

  • Version changed from 1.5.5 to 1.5.4

Any danger of this being sneaked into 1.6.1 or 1.7?

#7 @DJPaul
11 years ago

No, not for 1.7.

#8 @sooskriszta
11 years ago

  • Keywords needs-ui added

#9 @karmatosed
11 years ago

  • Cc karmatosed@… added

#11 @sooskriszta
10 years ago

  • Cc vivek@… added
  • Component changed from UX/UI to All Components
  • Keywords needs-patch added; needs-ui removed
  • Summary changed from Add admin panel options to change component names and slugs to Grab component page title from the WordPress page title.

Slug constants are deprecated: http://codex.buddypress.org/getting-started/customizing/changing-internal-configuration-settings/
which is mostly fine as BuddyPress asks you which page to use for each component (e.g. Groups, Members etc) and even creates the pages for you. if you want to change the slug, no sweat...just edit the page normally in WordPress and change the slug as you would for any normal page or post. Fantastic!

However, the problem is that in the frontend, instead of using the page titles as set in WordPress, BuddyPress continues to use hardcoded component names as the page titles. e.g. If you tell BuddyPress to use the page Schools (with slug schools) as the Groups list/page, then BuddyPress faithfully uses the correct page, and the slug is schools. But when you visit the page in frontend, the title shown is Groups, not Schools. This can't possibly be correct. BuddyPress should grab the page titles from WordPress too.

#12 @mercime
10 years ago

  • Cc mercijavier@… added

#13 @sooskriszta
9 years ago

Did someone say that jjj is working on this?

#14 @DJPaul
8 years ago

  • Component changed from Component - Any/All to Core

#15 @DJPaul
8 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

Top-level (directory) slugs can be changed via the legacy constants of the post_name of the page mapped to that component. URL slugs underneath that hierarchy can't be customised like this.

We have ticket(s) open for rewrite rules, and we'll have to support this kind of thing when we implement that.

#16 @sooskriszta
8 years ago

@DJPaul Perhaps I have not explained the ticket well. What I am talking about is slightly different than slugs (even though slugs were included in OP).

BuddyPress is used in many different contexts. So, admin should be able to customize the component names. If someone wants to call Groups Rooms or Teams or Choirs or Cities or Classes or Chapters, they should be able to do so.

Similarly if someone wants to call Members Singers or Students or Players or Officers, they should be able to do so.

etc

#17 @sooskriszta
6 years ago

In case someone is interested, https://wordpress.org/plugins/bp-power-seo/ does this.

#18 @sooskriszta
6 years ago

In case someone is interested, https://wordpress.org/plugins/bp-power-seo/ does this.

*Partially*

Note: See TracTickets for help on using tickets.