Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4106 closed defect (bug) (worksforme)

Custom Post Type Comments not showing in Activity Stream

Reported by: bofw Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.4
Component: Core Keywords:
Cc:

Description

Hi Guys

Working on custom post types at the moment, but can’t get comments on them to appear in the activity stream.

This code will have the post appear but not the comments.

function activity_publish_custom_post_types($cpts) {
   $cpts[] = 'galleries';
   $cpts[] = 'downloads';
   return $cpts;
}
add_filter ( 'bp_blogs_record_post_post_types', 'activity_publish_custom_post_types' );
add_filter ( 'bp_blogs_record_comment_post_types', 'activity_publish_custom_post_types' );

Any IDeas?

Change History (2)

#1 @boonebgorges
10 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce your issue on the latest trunk. I registered some post types:

function bp_4106_rpt() {
	register_post_type( 'galleries', array(
		'public' => true,
		'label' => 'Galleries',
		'supports' => array( 'title', 'editor', 'comments' )
	) );
	register_post_type( 'downloads',array(
		'public' => true,
		'label' => 'Downloads',
		'supports' => array( 'title', 'editor', 'comments' )
	) );
}
add_action( 'bp_init', 'bp_4106_rpt' );

and then used your exact code. New posts and comments showed up in the stream as expected.

You may want to redirect your question to the support forums, as there could be an issue with the way you're registering the post type, or something like that. In the meantime, I'll close this ticket, but feel free to reopen if you can narrow this down to a reproducible problem with BP itself.

#2 @DJPaul
10 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.