Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#4097 closed defect (bug) (duplicate)

Error sending private message

Reported by: butch2059's profile butch2059 Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.4
Component: Messages Keywords:
Cc:

Description

I have the latest version on buddypress
I have the latest version of BuddyPress Group Email Subscription
I have the latest version of BuddyPress Private Community ( all at default install)

when I try and send a "Private Message" I get sent to a page that says "Oops! This link appears to be broken." however when I check my sent box the message is sent to the member. How can I fix the the page that says: "Oops! This link appears to be broken." from not happening.

Butch

Change History (19)

#1 follow-up: @boonebgorges
12 years ago

  • Keywords reporter-feedback added

What is the URL that shows in your browser on the "Oops!" page? (You can replace the domain with example.com if you want; we just need to see the format of the rest of the URL.)

#3 in reply to: ↑ 1 @butch2059
12 years ago

Replying to boonebgorges:

What is the URL that shows in your browser on the "Oops!" page? (You can replace the domain with example.com if you want; we just need to see the format of the rest of the URL.)

here is the URL

http://troop233.com/members/scout/messages/compose/

#4 @butch2059
12 years ago

I just got a confirmation back from some of my members that some of them dont get the "Oops!" page? they just get a Blank White Screen page

Thanks,

Butch

#5 follow-up: @boonebgorges
12 years ago

Is this happening when you use the BuddyPress Default theme?

#6 in reply to: ↑ 5 @butch2059
12 years ago

Replying to boonebgorges:

Is this happening when you use the BuddyPress Default theme?

Yes I am using BuddyPress Default 1.5.4 theme ( works perfect )

I also have an extra added question regarding the "Private Message" function .....shouldnt this function send an email directly to the individual member you are trying to contact at their registered email address when they joined through my wordpress site for example shouldnt the composed message go to their personal Mail Inbox like Yahoo,Gmail,SBC and not on my site in their buddypress inbox??

Butch

Last edited 12 years ago by butch2059 (previous) (diff)

#7 follow-up: @boonebgorges
12 years ago

Yes I am using BuddyPress Default 1.5.4 theme ( works perfect )

Now I'm confused - if it works perfect on BP Default, then can we close this ticket?

Private messages are within BP. If users have email notifications enabled, they also receive emails about them.

#8 in reply to: ↑ 7 @butch2059
12 years ago

Replying to boonebgorges:

Yes I am using BuddyPress Default 1.5.4 theme ( works perfect )

Now I'm confused - if it works perfect on BP Default, then can we close this ticket?

Private messages are within BP. If users have email notifications enabled, they also receive emails about them.

Ok thanks for that I understand now that the Private Message stays with in Buddypress .......Yes the Default 1.5.4 theme works perfect however I am still getting the "Oops!" page? or a blank white page when members send a "Private Message" and I never said that it was the Theme causing the problem I was just answering your question so I still need help to figure out how to fix this.......shouldnt you go to page in your profile or something after you send a Private Message and not a "Oops page" or a blank white page my members keep asking me about this........

Butch

#9 follow-up: @boonebgorges
12 years ago

I never said that it was the Theme causing the problem

I didn't say you did. I was trying to determine whether it was the theme causing it.

Please deactivate all plugins other than BuddyPress and see whether the problem persists.

#10 in reply to: ↑ 9 ; follow-up: @butch2059
12 years ago

Replying to boonebgorges:

I never said that it was the Theme causing the problem

I didn't say you did. I was trying to determine whether it was the theme causing it.

Please deactivate all plugins other than BuddyPress and see whether the problem persists.

Sorry for the confusion..... ok I will give that a try and get back to you thanks

#11 in reply to: ↑ 10 @butch2059
12 years ago

Replying to butch2059:

Replying to boonebgorges:

I never said that it was the Theme causing the problem

I didn't say you did. I was trying to determine whether it was the theme causing it.

Please deactivate all plugins other than BuddyPress and see whether the problem persists.

Sorry for the confusion..... ok I will give that a try and get back to you thanks

Ok I did that and still no change did not solve the problem

I can give you a test account to my site so you can see what I am talking about

Last edited 12 years ago by butch2059 (previous) (diff)

#12 follow-up: @boonebgorges
12 years ago

Thanks for trying. This narrows down the possible place where the error is taking place.

Are you finding that email notifications and BuddyPress notifications (the one in the Notifications dropdown) are working when new email messages are sent?

If you have access to your PHP error log, it would be extremely helpful if you could provide any Fatal Error data you find there. If not, you may consider turning on WP_DEBUG for a moment, attempting to send a message, and then taking note of the error message (if any) displayed after you send a message. Enable WP_DEBUG by finding the following line in wp-config.php:

define( 'WP_DEBUG', false );

and changing it to

define( 'WP_DEBUG', true );

Note that you should only leave it set to true for as long as it takes to run the test - turn it back to false as soon as you are done.

#13 in reply to: ↑ 12 @butch2059
12 years ago

Replying to boonebgorges:

Thanks for trying. This narrows down the possible place where the error is taking place.

Are you finding that email notifications and BuddyPress notifications (the one in the Notifications dropdown) are working when new email messages are sent?

If you have access to your PHP error log, it would be extremely helpful if you could provide any Fatal Error data you find there. If not, you may consider turning on WP_DEBUG for a moment, attempting to send a message, and then taking note of the error message (if any) displayed after you send a message. Enable WP_DEBUG by finding the following line in wp-config.php:

define( 'WP_DEBUG', false );

and changing it to

define( 'WP_DEBUG', true );

Note that you should only leave it set to true for as long as it takes to run the test - turn it back to false as soon as you are done.

Ok here is what I got when I changed the DEBUG:

Fatal error: Call to undefined function bp_get_settings_slug() in /usr/home/troop233/www/htdocs/wp-content/plugins/buddypress/bp-messages/bp-messages-notifications.php on line 20

And yes I can go back into the site and see all notifications I can go into my sent box and see all messages sent........it all looks like it is working ok but that Oops page or blank white page.

Last edited 12 years ago by butch2059 (previous) (diff)

#14 follow-up: @boonebgorges
12 years ago

  • Keywords reporter-feedback removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for the debug info. The problem is arising because you have the Settings component disabled. The bug is noted in #3996 and will be fixed in BP 1.5.5 in the upcoming days.

In the meantime, you can fix the problem by doing one of the following:

1) Enable the Settings component
2) Put the following in your bp-custom.php file:

if ( !function_exists( 'bp_get_settings_slug' ) ) :
    function bp_get_settings_slug() {
        return 'settings';
    }
endif;

Be sure to remove the function after upgrading to BP 1.5.5.

#15 in reply to: ↑ 14 @butch2059
12 years ago

Replying to boonebgorges:

Thanks for the debug info. The problem is arising because you have the Settings component disabled. The bug is noted in #3996 and will be fixed in BP 1.5.5 in the upcoming days.

In the meantime, you can fix the problem by doing one of the following:

1) Enable the Settings component
2) Put the following in your bp-custom.php file:

if ( !function_exists( 'bp_get_settings_slug' ) ) :
    function bp_get_settings_slug() {
        return 'settings';
    }
endif;

Be sure to remove the function after upgrading to BP 1.5.5.

Where is the bp-custom.php file located ...........cant find it .....is this something I make or what I am confused ......how long until the update happens...I am not a programmer so I am not to sure about making this change can you help?

Last edited 12 years ago by butch2059 (previous) (diff)

#16 follow-up: @butch2059
12 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

#17 in reply to: ↑ 16 @butch2059
12 years ago

Last edited 12 years ago by butch2059 (previous) (diff)

#18 @butch2059
12 years ago

Last edited 12 years ago by butch2059 (previous) (diff)

#19 @boonebgorges
12 years ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

You can find more information about bp-custom.php here: http://codex.buddypress.org/extending-buddypress/bp-custom-php/

Note: See TracTickets for help on using tickets.