Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

Last modified 8 years ago

#4094 closed defect (bug) (worksforme)

Doesn't remove slashes from emails when sending validation email

Reported by: holizz Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords: reporter-feedback
Cc:

Description

This means people with quotes in their email address can't sign up.

In function bp_core_signup_send_validation_email (bp-members/bp-members-signup.php:568).

I attach a patch that works, but perhaps $user_email should be un-slashed at some earlier point.

Attachments (1)

patch (495 bytes) - added by holizz 9 years ago.

Download all attachments as: .zip

Change History (7)

@holizz
9 years ago

#1 @cnorris23
9 years ago

Good catch. I never knew quotes were even valid in the local part of an email address. Since this is the case, we should check other areas of the code to make sure they too, have their slashes stripped.

#2 @DJPaul
9 years ago

  • Milestone changed from Awaiting Review to 1.6
  • Owner set to DJPaul
  • Status changed from new to assigned

#3 @DJPaul
9 years ago

  • Owner DJPaul deleted

#4 @DJPaul
9 years ago

  • Keywords reporter-feedback added
  • Milestone changed from 1.6 to Future Release

Can you supply a sample email address that I can use to recreate the problem? I can't get the email address in bp_core_signup_send_validation_email() to be slashed.

#5 @holizz
9 years ago

  • Resolution set to worksforme
  • Status changed from assigned to closed

I tried to reproduce this and couldn't, so I'll close it.

#6 @johnjamesjacoby
8 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.