Skip to:
Content

BuddyPress.org

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#409 closed defect (bug) (fixed)

Admin Bar Login URL Wrong

Reported by: trent Owned by: apeatling
Milestone: Priority: major
Severity: Version:
Component: Keywords:
Cc:

Description

The admin bar "Login" link is putting the main blog in with the destination blog as redirect. This breaks any logins to sites that use domain mapping.

http://mainblog.com/wp-login.php?redirect_to=http%3A%2F%2Fblog2.mainblog.com%2F

Change History (5)

#1 @apeatling
11 years ago

The problem is the "redirect_to" part, not the "main blog" part?

#2 @trent
11 years ago

  • Milestone set to Core 1.0

Sorry, should have been more clear. When logging in off the "login" link of admin bar while viewing blog2, it is showing:

http://mainblog.com/wp-login.php?redirect_to=http%3A%2F%2Fblog2.mainblog.com%2F

when it should be:

http://blog2.mainblog.com/wp-login.php?redirect_to=http%3A%2F%2Fblog2.mainblog.com%2F

And if you were viewing blog99 it would then be:

http://blog99.mainblog.com/wp-login.php?redirect_to=http%3A%2F%2Fblog2.mainblog.com%2F

#3 @trent
11 years ago

that last example meant to have blog99 in redirect as well....whoops!

#4 @apeatling
11 years ago

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r969, thanks.

#5 @(none)
10 years ago

  • Milestone Core 1.0 deleted

Milestone Core 1.0 deleted

Note: See TracTickets for help on using tickets.