Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#4067 closed defect (bug) (no action required)

'Create a Group' button not working

Reported by: fitmogul's profile fitmogul Owned by: david's profile David
Milestone: Priority: normal
Severity: normal Version: 1.5.4
Component: Groups Keywords:
Cc:

Description

Hi-

I believe I discovered a bug in buddypress. When I go to My Account>Groups and then click the 'create a group' button, it redirects me to www.fitmogul.com/groups/create but then displays 'Page Not Found'. However, when I go to the 'Groups Directory' page and click 'Create a Group', it redirects me to http://www.fitmogul.com/social/friends-request/create/step/group-details/ and it works fine. I suppose my question is, where can I change the redirect path for the broken button from '/groups/create' to '/social/friends-request/create/step/group-details/'. I believe this should fix it. Any thoughts is much appreciated, thanks!

-David

Change History (1)

#1 @boonebgorges
12 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

The BuddyPress Default theme doesn't appear to have a 'Create a Group' button on My Account > Groups (unless I'm missing something!). Maybe the button is added by a theme?

In any case, it appears that the theme (or whatever it is that's adding the button) has done it in the wrong way - either by hardcoding the URL, or by using the (deprecated) $bp->groups->slug for constructing, instead of bp_get_groups_root_slug(), which is messing things up because your groups page is not called 'groups' but 'friends-request'.

I'm closing this ticket because I think it's an issue with your custom theme. If you need further support with this issue, you might think about contacting the theme author, or posting a topic on http://buddypress.org/support. If it turns out that this is caused by a bug in BP, feel free to reopen the ticket with further details. Thanks!

Note: See TracTickets for help on using tickets.