Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#4043 closed defect (bug) (fixed)

Border below moderators list when managing members

Reported by: davidtcarson Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version:
Component: Core Keywords: has-patch
Cc:

Description

Very minor. But, in bp-default, there is a 1px border that displays beneath list of moderators (when they exist) on group manage members page. That border is courtesy of the item-list class in #mods-list. The border is removed from beneath admin list because #admins-list has been assigned the class single-line.

Patch attached adds single-line class to #mods-list to remove border.

Screenshot and patch attached.

Attachments (2)

4043_1.diff (582 bytes) - added by davidtcarson 10 years ago.
add class
4043.png (28.6 KB) - added by davidtcarson 10 years ago.
Screenshot of border

Download all attachments as: .zip

Change History (6)

@davidtcarson
10 years ago

add class

@davidtcarson
10 years ago

Screenshot of border

#1 @davidtcarson
10 years ago

Quick follow-up.

I tried to find out what the single-line class was being used for. Looks like a legacy class from older version of bp-default. http://buddypress.trac.wordpress.org/ticket/3271#comment:16

Not sure why that class is missing from #mods-list when it's been added to #admins-list and #members-list on the manage group members section, but 4043_1.diff does at least keep the presentation of those lists consistent in bp-default (no borders beneath li) and could make life a little easier for child themes.

#2 @DJPaul
10 years ago

I suspect it was intended as a visual dividers between the sections, but like you say, it doesn't add much value and it is a bit odd. I'll add your patch.

#3 @DJPaul
10 years ago

  • Milestone changed from Awaiting Review to 1.6

#4 @djpaul
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5879]) Make lists on group admin > members screen have a consistent style. Props davidtcarson.
Also add clearing to those lists to make spacing consistent. Fixes #4043

Note: See TracTickets for help on using tickets.