Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 10 years ago

Last modified 8 years ago

#4028 closed defect (bug) (duplicate)

user_nicename/user_login usage needs an audit

Reported by: johnjamesjacoby's profile johnjamesjacoby Owned by: johnjamesjacoby's profile johnjamesjacoby
Milestone: Priority: highest
Severity: major Version:
Component: Core Keywords:
Cc:

Description

We are inconsistently using 'login' 'user_login' 'user_nicename' and compatibility mode in several places in BuddyPress core. This needs an audit, so let's commit fixes to this as we go.

Change History (4)

#1 @johnjamesjacoby
12 years ago

(In [5811]) Use correct field when in username compatibility mode in bp_core_set_uri_globals(). See #4028.

#2 @DJPaul
12 years ago

  • Milestone changed from 1.6 to Future Release

Moving this to the future release milestone as it is an ongoing task, and investigation is required to identify what parts we need to correct. I looked a few months ago and everything seemed correct, so maybe I misunderstand the ticket.

#3 @johnjamesjacoby
10 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing this as a duplicate of #5185, which has had a ton more attention than this generic placeholder.

#4 @DJPaul
8 years ago

  • Component changed from Component - Any/All to Core
Note: See TracTickets for help on using tickets.