Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#4004 closed defect (bug) (fixed)

Group Forums cannot be uninstalled?

Reported by: ericlewis's profile ericlewis Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version: 1.5.3
Component: Forums Keywords: dev-feedback
Cc: mercijavier@…

Description

While working on a patch for http://buddypress.trac.wordpress.org/ticket/3984 I found another bug related to Group Forums.

Group Forums can be enabled, but not disabled?

To reproduce:

  1. Install WP multisite
  2. Install BP with BP_ENABLE_MULTIBLOG enabled
  3. Navigate to BP Settings > Forums
  4. Install Group Forums
  5. Enable group forums on a group
  6. Uninstall Group Forums

At this point, group forums will still be present when viewing a group, although you've "uninstalled" it via the Forum Settings page.

Change History (13)

#1 @ericlewis
12 years ago

You actually don't need to add the BP_ENABLE_MULTIBLOG enable to see this bug, and as the "Install Group Forums" link will not currently work if you enable it, don't. You can see the error if you just install WordPress on a multisite install.

And I actually just tested this in a non-multisite environment, so you don't even need that going to see the bug.

Version 0, edited 12 years ago by ericlewis (next)

#2 @johnjamesjacoby
12 years ago

  • Component changed from Core to Forums
  • Milestone changed from Awaiting Review to 1.6
  • Version set to 1.5.3

The logic here is a little weird. I'll be sure to fix this with bbPress 2 integration.

#3 @mercime
12 years ago

  • Cc mercijavier@… added

At present, manual deletion of bb-config.php created when Group Forums were installed is required to complete uninstallation of Group Forums.

#4 follow-up: @boonebgorges
12 years ago

What's the goal of *uninstalling* group forums? Why not just disable the forums component?

#5 in reply to: ↑ 4 @ericlewis
12 years ago

Replying to boonebgorges:

What's the goal of *uninstalling* group forums? Why not just disable the forums component?

That would work too, it could be resolved as a UX issue like that and take out the uninstall button.

#6 @boonebgorges
12 years ago

  • Keywords dev-feedback added

Hm, that's an interesting idea. What do other devs think about that?

#7 @DJPaul
12 years ago

Taking out the button (which currently just clears the 'bb-config-location' option) or making it also disable the Forums component?

I don't think we can take the button out, because that option is used by bp_forums_is_installed_correctly() to check if bbPress 1 is "installed" correctly. Making the button disable the Forums component adds more value to the button; an alternative would be to put up a message that tells people they then need to go to Components and deactivate Forums, etc, which seems a bit long-winded.

#8 @boonebgorges
12 years ago

that option is used by bp_forums_is_installed_correctly() to check if bbPress 1 is "installed" correctly

I don't think it'll be crucial if we revert the group forum component in the way suggested in #4258 (https://buddypress.trac.wordpress.org/attachment/ticket/4258/4258.01.patch). Or maybe I'm misunderstanding?

#9 @DJPaul
12 years ago

I pre-assumed that the forum screen goes back to looking like it does in 1.5. I thought this ticket was about why the "uninstall forums" button doesn't actually uninstall the forums (i.e. disabling the component), because it currently just clears a database option.

#10 follow-up: @boonebgorges
12 years ago

So what *would* it do? Delete bb-config.php? Drop the database tables? If either of these is the idea, I think we should wontfix. Deleting data from the interface is a bad idea. And deleting bb-config.php would be a new feature that I don't think is worth implementing at the moment. All of this will be moot when we move to bbPress 2.x.

#11 in reply to: ↑ 10 @DJPaul
12 years ago

So what *would* it do?

Is the bbPress 2.1 integration at all dependant on the Forums component being active? If there is no dependancy, we could make this button deactivate the Forums component. If there is a dependancy… rename "Uninstall Group Forums" to "Reinstall Group Forums" and call it a day.

#12 @boonebgorges
12 years ago

If there is a dependancy… rename "Uninstall Group Forums" to "Reinstall Group Forums" and call it a day.

Ding ding! We have a winner! I'm not certain that there is a dependency between bbPress 2.x and the Forums Component (I don't think so - bbPress registers its own component) but I don't think it matters much because this button explicitly refers to *group* forums anyway. "Reinstall" is a much more accurate description of what this button does, and has always done.

I'm leaving the ticket open because it can't be fixed until #4258 has been closed.

#13 @djpaul
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6110]) On the Forums admin screen, rename the "Uninstall Group Forums" button to "Reinstall Group Forums" as this is a much better description of what the button does/has always done. Fixes #4004

Note: See TracTickets for help on using tickets.