Skip to:
Content

BuddyPress.org

Opened 8 years ago

Closed 8 years ago

Last modified 3 years ago

#3994 closed enhancement (duplicate)

Use functions instead of $bp global when referencing user data

Reported by: johnjamesjacoby Owned by:
Milestone: 1.6 Priority: normal
Severity: minor Version: 1.5.3
Component: Core Keywords:
Cc:

Description

We still directly reference $bp->loggedin_user->domain and $bp->displayed_user->domain in many places, when we should be using bp_loggedin_user_domain() and bp_displayed_user_domain(), respectively.

Same goes for many of the other userdata related references.

These should be switched over to their functions.

Change History (4)

#1 @johnjamesjacoby
8 years ago

(In [5704]) Replace direct references to $bp user domains with their functional equivalents. See #3994.

#2 @johnjamesjacoby
8 years ago

(In [5705]) Replace direct references to $bp user fullname and user_login with their functional equivalents, and kill off some $bp global usage in the process. See #3994, #3989.

#3 @johnjamesjacoby
8 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Was actually a dupe of #3989. Closing as fixed.

#4 @DJPaul
3 years ago

  • Type changed from task to enhancement
Note: See TracTickets for help on using tickets.