Skip to:
Content

BuddyPress.org

Opened 9 years ago

Closed 9 years ago

#3984 closed defect (bug) (duplicate)

Forum tab error

Reported by: flemmingbjerke Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version: 1.5.3
Component: Forums Keywords:
Cc:

Description

Having updated buddypress from 1.2.9 til 1.5.3.1, I had to re-activate forums. However, two of the buttons at the forums-tab did not work. For instance, the "Use existing installation" button does not work because its link is:

http://example.org/wp-admin/network/admin.php?page=bb-forums-setup&step=existing

If you copy this into the browsers url-field, removing "/network", it works, and the forums are re-activated. Probably, it is the same problem with the "Install Group Forum" button.

Actually, there is no such file: wp-admin/network/admin.php in the network folder. The relevant code seems to be found in:

buddypress/bp-forums/bp-forums-admin.php

<a class="button button-primary" href="<?php echo $post_url . '&s\
tep=new' ?>"><?php _e( 'Install Group Forums', 'buddypress' ) ?></a> &nbsp;
<a class="button" href="<?php echo $post_url . '&step=existing' ?\
>"><?php _e( 'Use Existing Installation', 'buddypress' ) ?></a>

But, I don't understand how "/network" comes into $post_url when the url of forums page is:

http://example.org/wp-admin/admin.php?page=bb-forums-setup

Change History (6)

#1 @flemmingbjerke
9 years ago

I forgot to tell that it is a multisite wp. That might explain the "/network"?

#2 @flemmingbjerke
9 years ago

Actually, the bug turned up at a test-site. But, when I updated the production site, I did not need to re-activate forums, and the un-install button at the forums-admin site has no "/network" in its url.

I guess it is not easy to reproduce the bug - and by the way, the bug may be due to speciel circumstances at my testsite. Anyhow, now I have described it, and others might find this bug track so that it might be confirmed, and the workaround is very simple.

#3 @ericlewis
9 years ago

This is a serious bug.

To reproduce:

+ Create multisite install
+ Enable BP Multiblog, install BP
+ Navigate to BuddyPress > Forums settings page
+ Click either of the links to set up forums for groups

The issue stems from the fact that when you enable multiblog in BuddyPress, all the BuddyPress settings are taken to the site level, and there are no network settings pages for BuddyPress anymore.

It's also a bit of a tricky bug, as all multiblogs will use the same check to see if forums are already installed ( does the bbconfig file exist ), and therefore any site admin could turn of group forums for the entire network.

Seems that group forums should perhaps have a site option to record whether they are installed or not for that site.

#4 @boonebgorges
9 years ago

  • Milestone changed from Awaiting Review to 1.6

I'm not sure if it's the cause of the OP's issue, but I can see from ericlewis's comment that this is indeed a problem for BP_ENABLE_MULTIBLOG.

Seems that group forums should perhaps have a site option to record whether they are installed or not for that site.

This is fine as a long-term solution, as I think it'll raise a bunch of smaller issues. In the short term, we could consider adding a note under the Uninstall Group Forums button when MULTIBLOG is enabled, explaining that disabling for one site will disable for the whole network. Also, that button should only be visible to super admins, not site admins.

#5 @johnjamesjacoby
9 years ago

This will be a non issue as installations gradually move towards bbPress 2. It's annoying now and we should put some checks in to ensure nothing gets nooped, but this issue will phase itself out.

#6 @johnjamesjacoby
9 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Going to close this as a dupe of #3598. See above comment.

Note: See TracTickets for help on using tickets.