Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 8 years ago

#3965 closed enhancement (no action required)

New blog posts to activity wall get messed up with html comment tags

Reported by: username_'s profile username_ Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.3
Component: Core Keywords: 2nd-opinion
Cc:

Description

When I post a new blog post in the wordpress dashboard, It usually gets posted to the main activity wall. This part works fine but what gets posted doesn’t. I tested it out and it seems if there are comments inside the posts like <!-- comments --> this well show up as “comments” on the activity wall. On the actual post on the wordpress part it does not show up. Like I mentioned previously. this worked fine on 1.2.9 but now on the 1.5.3.1 version this part seems to be not working properly. I tried the bp-default theme and still same thing. I didn’t think this would be a theme thing. more of a core part, but I like to test before posting here.

Change History (4)

#1 @DJPaul
12 years ago

  • Milestone changed from Awaiting Review to Future Release
  • Severity changed from major to normal
  • Type changed from defect (bug) to enhancement

A HTML comment does make its way into the activity stream -- which is probably harmless but not desirable -- but the tags remain (e.g. I don't just get the word "comments" in the activity stream).

username_: how long a blog post were you testing this one? Have you got a site to share an example on so we can look at the activity stream HTML?

#2 @username_
12 years ago

I have tested this on mostly short blog posts. Consisting of a few words and some of no words other than just comments. I tested mostly with some of the flash video posts that I have.

In these flash video blog posts I have Internet explorer comment checks to display a specific video format for IE users. This code looks like this. <!-- [if !IE] --> and shows up on the activity stream as "-- [if !IE] -->" . I tested with just regular comments like <!-- comments --> and they showed up as "comments". I can further test and look into this later tonight.

Unfortunately the site I run buddypress on is a private community and can not be accessed unless you set up an account. but feel free to set up an account if you'd like it is free. it is at www.aapltrader.com.

Last edited 12 years ago by username_ (previous) (diff)

#3 @DJPaul
12 years ago

  • Keywords 2nd-opinion added

Still can't recreate. can anyone else?

#4 @mercime
8 years ago

  • Milestone Future Release deleted
  • Resolution set to invalid
  • Status changed from new to closed

As of BP 2.7 trunk. Tested adding <!-- comments --> and <!-- [if !IE] --> in blog posts and the comments are not showing up in Activity Stream.

Note: See TracTickets for help on using tickets.