Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#3950 closed enhancement (fixed)

404 Error Logout

Reported by: ninos-ego's profile Ninos Ego Owned by:
Milestone: 1.6 Priority: normal
Severity: minor Version:
Component: Core Keywords: needs-patch
Cc:

Description

Logout on the page DOMAIN.TLD/community/members/USER/profile/edit/group/1/ and some urls like this the user will get a 404 Error after logout.

I've got the newest trunk version 5646

Change History (4)

#1 @DJPaul
12 years ago

  • Keywords dev-feedback added

This is expected behaviour; logging out takes you back to where you were. The URL 404s because it is a restricted page (obviously). I suggest wontfix because it's a bit of an edge case; any feedback from other devs?

#2 @johnjamesjacoby
12 years ago

  • Keywords needs-patch added; dev-feedback removed
  • Milestone changed from Awaiting Review to 1.6
  • Type changed from defect (bug) to enhancement

Would be nice to at least bump them to the domain root if we can catch a 404 on the redirect. Moving to 1.6 to get some eyes on it.

#3 @ericlewis
12 years ago

Perhaps an error message after redirect to homepage with a "you lack permissions to view that page" text. Might be nice but not necessary.

#4 @boonebgorges
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5771]) Pass wp_guess_url() to wp_logout_url() in sidebar logout widget. Fixes #3950.

Note: See TracTickets for help on using tickets.