Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#3945 closed defect (bug) (duplicate)

The at mentions functionality does not work when the username is followed by a full stop

Reported by: kwerri's profile kwerri Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.3
Component: Activity Keywords:
Cc:

Description

Repro steps:

  1. Get a username of a user on a site that uses BuddyPress. Let's call this username.
  1. Make a comment on a post, including the text @username. (i.e. the at sign followed by username followed by a full stop.
  1. Observe that the username is not converted into a link to the user's BuddyPress profile.

The problem seems to be with the regex pattern that is used to determine at-mentions in posts. This is in the bp_activity_find_mentions functions in wp-content/plugins/buddypress/bp-activity/bp-activity-functions.php

The pattern is /[@]+([A-Za-z0-9-_\.@]+)/, but it should be /[@]+([A-Za-z0-9-_\.@]+[A-Za-z0-9-_@])/

Change History (2)

#1 @r-a-y
12 years ago

See #3721.

This is fixed in trunk. Can you test the fix and see if it works for you?

#2 @DJPaul
12 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3721, fixed in 1.6-trunk.

Note: See TracTickets for help on using tickets.