Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 7 years ago

#3935 closed defect (bug) (wontfix)

Members directory does not generate correct HTML (form inside form)

Reported by: rogercoathup's profile rogercoathup Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.3
Component: Templates Keywords: needs-patch
Cc: rcain@…

Description

The search form nested inside the form for the members directory is not valid XHTML / HTML5 (forms can't be nested in forms).

As a result browsers terminate the members directory form after the search form, and not at the bottom of the members directory (as intended).


To fix: the search form (generated by bp_directory_members_search_form() function) should be moved outside of the form#members-directory-form

Note though: this introduces additional problems that should be fixed - i.e. the search of members works, but the search is also picked up by WP and an additional archive search performed.

Change History (9)

#1 @rogercoathup
12 years ago

please ignore last paragraph about archive search - that's not related to this problem

#2 @DJPaul
12 years ago

  • Component changed from Core to Theme
  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to 1.6

Bit worried about backpat if we move this.

#3 @johnjamesjacoby
12 years ago

  • Milestone changed from 1.6 to Future Release

Agree this is bad form, but we're stuck with it for now. Moving to Future Release until we can decouple these forms.

#4 @rcain
11 years ago

  • Cc rcain@… added
  • Version changed from 1.5.3 to 1.6.1

Hi, did this ever get fixed please?
Is causing me a few headaches with base bp functionality + bad plugin behaviour around this point in code.
Am using wp 3.4.2 + bp 1.6.1.
Thanks.

#5 @DJPaul
11 years ago

  • Version changed from 1.6.1 to 1.5.3

Please don't change the version tag.

#6 @rcain
11 years ago

very sorry. mistake. any news on the bug?

#7 @DJPaul
11 years ago

If you're asking has it been fixed yet, no. :)

#8 @DJPaul
8 years ago

  • Component changed from Appearance - Template Parts to Templates

#9 @lakrisgubben
7 years ago

  • Milestone Future Release deleted
  • Resolution set to wontfix
  • Status changed from new to closed

This isn't a problem in the currently used bp-legacy "theme" (see: https://buddypress.trac.wordpress.org/browser/trunk/src/bp-templates/bp-legacy/buddypress/members/index.php) and since bp-default isn't supported anymore (see: https://bpdevel.wordpress.com/2013/11/13/the-future-of-the-bp-default-theme/) I'm closing this as wontfix.

Note: See TracTickets for help on using tickets.