Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3930 closed defect (bug) (no action required)

Warning Message appears when replying to a message

Reported by: llasalle's profile llasalle Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.2
Component: Core Keywords:
Cc:

Description

I'm using BuddyPress version 1.5.2 with the default theme. I have not seen this previously, but I am now seeing the following error/warning message when I reply to a message. It does not happen when sending a new message. The only thing I have changed on my site recently is implementing a sitewide forum. Not sure if that is related.

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /home/content/28/8075728/html/wp-content/plugins/buddypress/bp-themes/bp-default/_inc/ajax.php:540) in /home/content/28/8075728/html/wp-content/plugins/contact-form-plugin/contact_form.php on line 667

Change History (3)

#1 @r-a-y
10 years ago

Sounds like a conflict with the Contact Form plugin.

If possible, try one of the many, other contact form plugins available:
http://wordpress.org/extend/plugins/tags/contact

#2 @boonebgorges
10 years ago

  • Resolution set to invalid
  • Status changed from new to closed

It sounds like two things happening at once:

  • the Contact Form plugin is using a PHP session
  • you are using a plugin that displays content at bp_before_message_meta (that's line 540 of ajax.php). Perhaps BP Usernames Only?

Since neither of these would be caused by BP itself, I'm going to close this ticket. (You may want to consider turning down the warning level on your site, so that these kinds of warnings are not displayed to users.)

#3 @boonebgorges
10 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.