Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 7 years ago

Last modified 5 years ago

#3907 closed enhancement (duplicate)

Revise metas to allow multiple keys with same value

Reported by: DJPaul Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

All components' meta functions should allow multiple keys to be stored with the same value (see WP's add_metadata() $unique).

We should probably also use WP's meta handling functions (add_metadata(), update_metadata(), and so on) to avoid code duplication and ensure meta feature parity.

Change History (6)

#1 @DJPaul
10 years ago

For the second thing, we will probably need to get a filter added to _get_meta_table(). I'll see if WP trac has a ticket. Another approach would be to add the table names to the $wpdb object.

Last edited 10 years ago by DJPaul (previous) (diff)

#2 @boonebgorges
9 years ago

  • Keywords needs-testing needs-unit-tests added

I like the idea of leveraging WP's meta functions, but I think that (as you note) there are some limitations in how table names are built.

I'd like for there to be decent test coverage for the existing functions before attempting to port.

#3 @r-a-y
8 years ago

Related: #4551

#4 @r-a-y
7 years ago

  • Keywords dev-feedback needs-testing needs-unit-tests removed
  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #4551.

#5 @johnjamesjacoby
7 years ago

  • Component changed from Component - Any/All to API - WordPress

#6 @DJPaul
5 years ago

  • Component changed from API - WordPress to Core
Note: See TracTickets for help on using tickets.