Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3905 closed enhancement (duplicate)

BP not fully uninstalled after following the codex instructions

Reported by: mindtweaks's profile MindTweaks Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

Hello, Awesome BuddyPress Code Monkeys!

Yesterday, I installed BP 1.5 on a fresh install of WP 3.3

Something went wrong (I may not have completed the wizard, I'm not sure) and the install was incomplete - none of the BP content was displaying on the associated pages.

I uninstalled BuddyPress as detailed here:

http://codex.buddypress.org/buddypress-site-administration/deleting-buddypress/ and attempted a re-install. The re-installation did not trigger the BP Install wizard. I saved the options on the components/pages/settings/forums tabs, but it didn't correct the problem, and it seemed that some BP information was still being stored somewhere, as it remembered the pages I'd set previously.

I found the bb-config file, renamed it, uninstalled the BP plugin, and dropped the BP database tables again, and re-installed again, with the same result: The installation wizard wasn't triggered, I didn't have a way of locating it and triggering it manually, and saving the individual options pages didn't change the way BP associated pages were being displayed.

I went through the process several times to be sure I'd followed all of the steps correctly. Nothing changed.

Today I started from scratch, re-installing a fresh copy of Wordpress, and the BP installation went fine. To test the issue, I uninstalled BP again, and tried reinstalling - the installation wizard was still not being triggered. The reinstalled plugin is, however, working correctly. (whew!)

I've seen the same issue coming up on the support forums, too, and it could be a major problem if the plugin needs reinstalling on an extablished site, so I thought it worth reporting - there's either something wrong, or a missing step in the uninstall instructions.

I'm using Buddypress 1.5.2
I've had the same reinstallation issue with both Wordpress 3.3 and 3.3.1

Here are the stats from my webhost in case you need them:
Apache version 2.2.19
PHP version 5.2.17
MySQL version 5.0.92-community
Architecture x86_64
Operating system linux
Perl version 5.8.8
Kernel version 2.6.18-238.19.1.el5.centos.plus

Hope this helps find the problem!
Tori Deaux

Change History (3)

#1 @r-a-y
12 years ago

  • Type changed from defect (bug) to enhancement

When you deactivate BuddyPress, currently none of BP's settings are deleted from the "wp_options" table.

The magic setting that will help you trigger a reinstall is the option_name "bp-db-version". Try deleting that from the "wp_options" table in the database and try again.

I'll add this and a little bit more info to the codex article now.

In the future, it might be wise for BuddyPress to include some form of manual clean up routine for people like yourself who want to completely start from scratch.

---

EDIT - Codex article is updated:
http://codex.buddypress.org/buddypress-site-administration/deleting-buddypress/

Last edited 12 years ago by r-a-y (previous) (diff)

#2 @DJPaul
12 years ago

  • Milestone changed from Awaiting Review to 1.6
  • Resolution set to duplicate
  • Status changed from new to closed

Ticket #2755 covers adding a uninstall.php which, amongst other things, could drop all the database tables and delete any BuddyPress items in the options tables.

#3 @r-a-y
12 years ago

Ahh, I missed that ticket!

Note: See TracTickets for help on using tickets.