Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#3876 closed defect (bug) (worksforme)

custom groups slug backwards compatibility problem (BP_GROUPS_SLUG)

Reported by: zbacsi's profile zbacsi Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.1
Component: Groups Keywords: reporter-feedback
Cc:

Description

In the file bp-groups/bp-groups-loader.php the BP_GROUPS_SLUG is defined ignoring the custom groups slug.

Line 67 should be changed from:

define( 'BP_GROUPS_SLUG', $this->id );

to:

define( 'BP_GROUPS_SLUG', isset( $bp->pages->groups->slug ) ? $bp->pages->groups->slug : $this->id );

Change History (2)

#1 @boonebgorges
12 years ago

  • Keywords reporter-feedback added

The logic that you describe already happens at https://buddypress.trac.wordpress.org/browser/trunk/bp-groups/bp-groups-loader.php#L80 As for line 67, BP_GROUPS_SLUG is only defined in this way if it's not already defined - which, in your case, it should be.

Can you give more details on how you are defining BP_GROUPS_SLUG? When I do it in my wp-config.php file:
define( 'BP_GROUPS_SLUG', 'foo' );
it works fine. Where and how are you defining yours?

#2 @johnjamesjacoby
12 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Can confirm this code works as intended in BuddyPress core. Closing as worksforme. Reopen if needed.

Note: See TracTickets for help on using tickets.