Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#3865 closed defect (bug) (fixed)

WSOD after upgrading to BP 1.6-bleeding

Reported by: r-a-y Owned by:
Milestone: 1.6 Priority: major
Severity: major Version:
Component: Core Keywords: dev-feedback
Cc:

Description

After switching to trunk and going through the update wizard, I get:

PHP Fatal error:  Call to undefined function bp_core_add_admin_menu() in /wp-content/plugins/buddypress/bp-core/admin/bp-core-update.php on line 1160

Please close if this a duplicate of #3802.

Change History (4)

#1 @sbrajesh
10 years ago

This error still persists and as far as I see the bp_core_add_admin_menu() is not defined anywhere in buddypress as of r5615

#2 @DJPaul
10 years ago

  • Keywords dev-feedback added
  • Milestone changed from Awaiting Review to 1.6
  • Priority changed from normal to major
  • Severity changed from normal to major

Ugh. This broke when the BP_Admin class was created (it's now BP_Admin::admin_menus). I don't know if this should have a backpat function in the deprecated file, too.

#3 @boonebgorges
10 years ago

(In [5656]) Reconfigures require() order for loading process during installation and upgrade.
Corrects outdated function calls and path names in installation wizard.
See #3740.
Fixes #3875. Fixes #3802. See #3865.

#4 @boonebgorges
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5657]) Deprecates bp_core_add_admin_menu().
Fixes #3865.

Note: See TracTickets for help on using tickets.