Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 9 years ago

Last modified 5 years ago

#3815 closed defect (bug) (fixed)

Template handling error when accessing member's profile edit URL

Reported by: DJPaul Owned by: johnjamesjacoby
Milestone: 1.7.1 Priority: normal
Severity: normal Version: 1.5.5
Component: Templates Keywords:
Cc:

Description

When logged out, when accessing a valid user's edit profile URL, rather than 404 or redirect (whichever is the correct behaviour for here), you get a weird partial template rendered.

Tested on http://testbp.org/members/djpaul/profile/edit/group/1 but not on a local copy.

Change History (9)

#1 @boonebgorges
10 years ago

Strange. On my local, I get a 404. (Probably should be a no-access-redirect, but a 404 is good enough.) Needs more testing.

#2 @johnjamesjacoby
10 years ago

  • Component changed from XProfile to Forums
  • Owner set to johnjamesjacoby
  • Status changed from new to assigned

That's bbPress 2.0 taking over. Assigning to myself to look at for 1.6.

#3 @johnjamesjacoby
10 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [5763]) Add an is_404() check to bp_is_user() to prevent partial matches from returning true. Fixes #3815.

#4 @r-a-y
9 years ago

  • Component changed from Forums to Core
  • Keywords dev-feedback added
  • Milestone changed from 1.6 to 1.7.1
  • Resolution fixed deleted
  • Status changed from closed to reopened
  • Version set to 1.5.5

r5763 breaks BP RSS feeds from displaying properly due to the is_404() check.

  • bp_is_user_activity() is used on all BP RSS action router functions to determine if we're currently on a BP user activity page.
  • bp_is_user() is used by bp_is_user_activity()

Since BP RSS feeds are 404 by default, the bp_is_user_activity() check will fail and the RSS feeds will not render properly.

Try out any of the following:

  • /members/admin/activity/friends/feed/
  • /members/admin/activity/groups/feed/
  • /members/admin/activity/mentions/feed/
  • /members/admin/activity/favorites/feed/

When I revert r5763, I can no longer duplicate DJPaul's initial report.

My recommendation is to revert r5763 and I'd like to fix this for 1.7.1.

Last edited 9 years ago by r-a-y (previous) (diff)

#5 @boonebgorges
9 years ago

See also #4329

I agree that the best thing to do here is revert r5763.

#6 @johnjamesjacoby
9 years ago

In 6947:

Revert r5763 as it introduced a regression in bp_is_user() behavior. See #3815.

#7 @johnjamesjacoby
9 years ago

  • Component changed from Core to Theme
  • Keywords dev-feedback removed
  • Resolution set to fixed
  • Status changed from reopened to closed

Can't duplicate anymore either, so marking as resolved.

#8 @r-a-y
8 years ago

In 6966:

Revert r5763 as it introduced a regression in bp_is_user() behavior.

See #3815 (1.7-branch).

#9 @DJPaul
5 years ago

  • Component changed from Appearance - Template Parts to Templates
Note: See TracTickets for help on using tickets.