Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#3812 closed defect (bug) (fixed)

Parameter 'include' blocks parameter 'type' in bp_has_members()

Reported by: janismo's profile janismo Owned by: janismo's profile janismo
Milestone: 1.6 Priority: normal
Severity: normal Version: 1.5.1
Component: Core Keywords: needs-patch
Cc: lv111@…

Description

If argument “include” is added to bp_has_members(), parameter “type” stops working, even if type is used as default (“active”).

Tested on clean BP 1.5.1.
In BP 1.2.10 combination of both parameters work fine.

Change History (4)

#1 @boonebgorges
12 years ago

Confirmed.

This is a weird one. It's due to this line: http://buddypress.trac.wordpress.org/browser/tags/1.5.1/bp-members/bp-members-template.php#L182 (see 184-5). That if clause was added a long time ago on the 1.2 branch but was then lost at one point along the line.

I don't think it does anything valuable, since the BP_Core_User::get() method takes an include() parameter. I'm taking it out.

#2 @boonebgorges
12 years ago

(I'm only going to fix this for the 1.6 release, because it's possible that there may be regressions in edge cases.)

#3 @boonebgorges
12 years ago

  • Milestone changed from Awaiting Review to 1.6

#4 @boonebgorges
12 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5458]) Don't use get_specific_users when an include parameter is passed to BP_Core_Members_Template. Fixes #3812

Note: See TracTickets for help on using tickets.