Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

#3768 closed defect (bug) (duplicate)

Name and Surname not registered (WordPress Multisite)

Reported by: alessioganci's profile alessioganci Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.1
Component: Members Keywords: reporter-feedback needs-testing
Cc:

Description

This bug occurred with WordPress Multisite. If a user try to register a BuddyPress account, his name and surname are registered in the database. But when the user activates his account, name and surname are not inserted into his profile (the field is empty).

Change History (8)

#1 @boonebgorges
12 years ago

  • Keywords reporter-feedback added

(the field is empty)

Which field are you talking about? By default, BP has a Name field that is synced with WP's display_name. BP does not, without modifications, sync first name and last name fields.

#2 @alessioganci
12 years ago

I am talking about the Name field of the BuddyPress profile. When I try to register an account,I fill also profiles fields. One of them is the Name field, that is compulsory. When I finish registering the account, I look to the phpMyAdmin table wp-signups. There is the account awaiting activation, and the field contains the following string:

a:3:{s:7:"field_1";s:6:"name_surname" (...)

So, data inserted in the field Name was successfully retrieved by BuddyPress. But when I activate the account via email, the string from wp_signups is removed and an account in wp_users is created. But when I go to wp_usermeta, I find that user data has been inserted, except the Name field. So, the account, when activated, loses data inserted in the Name field of profile, and, in the BuddyPress profile, is shown the username instead of the value of the field Name.

Last edited 12 years ago by alessioganci (previous) (diff)

#3 @boonebgorges
12 years ago

Have you changed the name of your 'Name' profile field?

#4 @boonebgorges
12 years ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to 1.5.2

#5 @AlessioGanci
12 years ago

Yes: when I was installing BuddyPress, I changed the name of the field 'Name', through the BuddyPress Admin Control Panel in WP-ADMIN (admin.php?page=bp-profile-setup&group_id=1&field_id=1&mode=edit_field), but I have not altered anything from the database (for example, IDs). And with all versions of BuddyPress (with last one) I have not encountered the bug. When I upgraded to the last one version, I decided to make WordPress as a MultiSite network, and my operations were successfully completed. However, when WordPress is MultiSite, I encounter the bug.

#6 @boonebgorges
12 years ago

  • Milestone changed from 1.5.2 to 1.5.3

This is probably a duplicate of #3683.

#7 @boonebgorges
12 years ago

  • Milestone changed from 1.5.3 to 1.5.4

#8 @johnjamesjacoby
12 years ago

  • Milestone 1.5.4 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

See #3725 for details. Closing as duplicate.

Note: See TracTickets for help on using tickets.