Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3759 closed defect (bug) (no action required)

Issues with members and blogs within buddypress/multisite environment

Reported by: iblbuilder Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5.1
Component: Blogs Keywords:
Cc:

Description

Re: This forum thread:

http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/multisite-buddypress-moving-from-multisite-non-buddypress-to-new-installation-with-buddypress/

My site is at http://6sided.net/ it is latest buddypress and latest WP versions. It has a modded theme, but even using BP default and deactivating all plugins other than BP, issue is still there.

Problem 1:

If a new member signs up at http://6sided.net/register/ and DOES create a blog on sign-up, the problems are:

  1. The "My Sites" dropdown shows two blog links,one is the blog they created, but the other is the main blog (http://6sided.net/) even though they do not have access to it.
  1. In their profile page it says they have 2 sites, again linking to the blog they created AND the main site. PNG example:

http://6sided.net/images/doublesites.png

Problem 2:

If they sign-up and do NOT create a blog on joining, they then cannot as the "my sites" menu is not displayed to them, giving them no way to create a blog.

So it is a two-part linked issue, depending on whether they create a blog on sign-up or not.

To reproduce:

  1. Create an account and create blog on signup http://6sided.net/register/
  2. My sites dropdown will shown own site and the erronous access to the main site dashboard
  3. Go to the user profile page and again see erronous access listed.
  1. Create account and do not create a blog at same time.
  2. My Sites menu does not exist.

Thanks

Jason

Change History (3)

#1 @boonebgorges
10 years ago

The first issue should be solved with r5338.

#2 @boonebgorges
10 years ago

  • Resolution set to invalid
  • Status changed from new to closed

The second issue is not a bug. If users want to create a new site, they can do so by visiting the Sites Directory and clicking Create Site at the top. If you would like to create a special navigation item in the admin bar that allows users to create new sites even when they don't have one already, you may do so with a plugin.

#3 @johnjamesjacoby
10 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.