Skip to:
Content

BuddyPress.org

Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#3713 closed defect (bug) (no action required)

Registration-> Upload Avatar -> Back to Registration Screen?

Reported by: justin-mason's profile justin mason Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5
Component: Core Keywords:
Cc:

Description

Issue: Once a user completes the registration page and uploads an avatar it takes them back to a clean registration page.

Problem: This is confusing. From a user perspective, taking me back to registration makes me think I need to re-input the data a second time around.

Possible Solution: Once avatar upload is complete, say "congratulations. Please confirm your account (confirmation sent via email) and enjoy the site." Then, after a timed delay, take them back to the home page.

Steps to reproduce:

1) Register
2) Upload Avatar
3) Hit submit

Completed registration and avatar upload brings you back to registration page with clear fields.

Change History (6)

#1 @justin mason
12 years ago

As a follow up, I tested out an earlier install of BP on another testing environment and found the registration and avatar upload system to work perfectly.

Is this an issue with 1.5.1 registration, or is there something server-side I should be looking into?

#2 @boonebgorges
12 years ago

  • Milestone changed from Awaiting Review to Future Release

Is this a fresh installation of BuddyPress? Default theme, no plugins? I seem to remember that avatar upload was taken out of registration in BP 1.5.

#3 @justin mason
12 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Did a clean install of BP 1.5.1 and set to default theme. Process works as intended.

Not sure exactly what went wrong in my custom theme. Hmm.

Thanks for clarifying the issue was on my end. Sorry for the trouble, bug marked as 'invalid'

#4 follow-up: @r-a-y
12 years ago

In your custom theme, mirror the changes from /bp-default/registration/register.php. You'll have to remove the avatar uploading section.

Thanks for reminding me about this issue. Will update the codex article about this.

EDIT - Codex article updated:
http://codex.buddypress.org/releases/1-5-developer-and-designer-information/

Scroll down to "Avatar uploading doesn’t work on the registration page".

Last edited 12 years ago by r-a-y (previous) (diff)

#5 in reply to: ↑ 4 @justin mason
12 years ago

Replying to r-a-y:

You are the man Ray - thank you for clearing that up. Appreciate your help!

In your custom theme, mirror the changes from /bp-default/registration/register.php. You'll have to remove the avatar uploading section.

Thanks for reminding me about this issue. Will update the codex article about this.

EDIT - Codex article updated:
http://codex.buddypress.org/releases/1-5-developer-and-designer-information/

Scroll down to "Avatar uploading doesn’t work on the registration page".

#6 @johnjamesjacoby
12 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.