Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

#3707 closed defect (bug) (fixed)

BP_DEFAULT_COMPONENT breaks other users' profile account URLs

Reported by: DJPaul Owned by:
Milestone: 1.6 Priority: normal
Severity: normal Version:
Component: Core Keywords:
Cc:

Description

If you set define('BP_DEFAULT_COMPONENT', 'messages'); in your wp-config.php, then try to visit another member's profile page when you are logged in (*not* your own), the page doesn't load; looks like a redirect loop.

Confirmed on 1.5.1 + trunk.

Change History (2)

#1 @Boonebgorges
10 years ago

I'm guessing this is an issue with the messages component in particular (since one can't access others' message screens) rather than with BP_DEFAULT_COMPONENT in general. Probably we shouldn't allow a private component like messages to be the default, or at least we should provide a fallback.

#2 @boonebgorges
10 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [5385]) Provides a valid fallback redirect for situations where the default component is set to something that is unavailable for the logged-in user (such as messages, when viewing someone else's profile). Fixes #3707

Note: See TracTickets for help on using tickets.