Skip to:
Content

BuddyPress.org

Opened 13 years ago

Closed 12 years ago

#3664 closed defect (bug) (worksforme)

Date field format change does not convert old values

Reported by: johnjamesjacoby's profile johnjamesjacoby Owned by:
Milestone: Priority: major
Severity: major Version:
Component: Extended Profile Keywords:
Cc:

Description

See #2240 and r5131.

We need to check for the old timestamp and convert it accordingly if it's the old format. Currently dates in the old format don't get processed at all and default to January 1, 1970 (UNIX epoch.)

Change History (4)

#1 @boonebgorges
13 years ago

It's converting correctly for me. Here's where it happens on the way out on the public end: http://buddypress.trac.wordpress.org/browser/tags/1.5/bp-xprofile/bp-xprofile-filters.php#L131 and here's where it happens on the Edit side of things: http://buddypress.trac.wordpress.org/browser/tags/1.5/bp-xprofile/bp-xprofile-template.php#L571

Could be that I missed something though. Can you give more details on how to reproduce?

#2 @cnorris23
13 years ago

I can't reproduce this either.

#3 @boonebgorges
12 years ago

One more bump before this gets closed as worksforme. jjj, if you get a chance, would you mind testing again?

#4 @boonebgorges
12 years ago

  • Keywords needs-patch removed
  • Milestone 1.5.2 deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.