Skip to:
Content

BuddyPress.org

Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#3648 closed defect (bug) (no action required)

Gravatars not working after BP 1.5 upgrade

Reported by: webby101 Owned by:
Milestone: Priority: normal
Severity: normal Version: 1.5
Component: Core Keywords: reporter-feedback
Cc:

Description

I have two sites one using pre 1.5 BP and another using 1.5 BP; other than that everything is identical. I have an account on each that uses the same email address. Both installs allow the display of Gravatars. After upgrading to 1.5, that install is NOT displaying my gravatar (or anyone elses) and instead displays the default avatar. The other version does display it. This leads me to conclude that there is an issue with gravatars being displayed on the new version of 1.5.

More people reporting the same issue here:
http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/gravatar-not-displaying-after-upgrade-to-1-5/

Change History (3)

#1 @boonebgorges
10 years ago

  • Keywords reporter-feedback added
  • Milestone changed from Awaiting Review to Future Release

I've done dozens of updates and have never seen this issue. Are you running any other plugins that might affect avatars? Are you able to do some debugging inside the bp_core_fetch_avatar() function to see what's up? In particular, the section beginning
if ( ! apply_filters( 'bp_core_fetch_avatar_no_grav', $no_grav ) ) {

Moving to future release until we get steps to reproduce.

#2 @cklosows
10 years ago

  • Resolution set to invalid
  • Status changed from new to closed

Just browsing tickets looking for quick cleanups, reported 9 months ago, Forum posts talking about this show it may have been due to a rogue mobile plugin:

http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/gravatar-not-displaying-after-upgrade-to-1-5/

http://buddypress.org/community/groups/how-to-and-troubleshooting/forum/topic/is-gravatar-supposed-to-work-in-1-5/

I'm going to close this thing out as 'invalid' since we're coming up on the 1.6 release. If anyone objects reopen it.

#3 @DJPaul
10 years ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.